aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-28 12:13:26 +0800
committer宋文武 <iyzsong@gmail.com>2016-05-02 22:06:45 +0800
commitf3045a5ba3da10bc971075ea206e55e8d21f5422 (patch)
tree5bee88e9e7e840517b93a4fa5738d0bbec781bea /gnu/packages/gnome.scm
parent0ddba7070771baee03745e9756fc4faefcf37701 (diff)
downloadguix-f3045a5ba3da10bc971075ea206e55e8d21f5422.tar
guix-f3045a5ba3da10bc971075ea206e55e8d21f5422.tar.gz
gnu: librsvg: Drop 'loaders.cache' file.
This is a followup to 05c4b7e93. * gnu/packages/gnome.scm (librsvg)[arguments]: Don't install 'loaders.cache' file. * gnu/packages/gnome.scm (gnome-themes-standard), gnu/packages/key-mon.scm (keymon), gnu/packages/music.scm (solfege): Remove wrap phase for SVG support.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm34
1 files changed, 4 insertions, 30 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0cc5ced1d2..2d7c206f8f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -880,7 +880,7 @@ dealing with different structured file formats.")
(arguments
`(#:phases
(alist-cons-before
- 'configure 'augment-gir-search-path
+ 'configure 'pre-configure
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "gdk-pixbuf-loader/Makefile.in"
;; By default the gdk-pixbuf loader is installed under
@@ -889,24 +889,10 @@ dealing with different structured file formats.")
(string-append "gdk_pixbuf_moduledir = "
"$(prefix)/lib/gdk-pixbuf-2.0/2.10.0/"
"loaders\n"))
- ;; Likewise, create a separate 'loaders.cache' file.
+ ;; Drop the 'loaders.cache' file, it's in gdk-pixbuf+svg.
(("gdk_pixbuf_cache_file = .*$")
- "gdk_pixbuf_cache_file = $(gdk_pixbuf_moduledir).cache\n")))
- (alist-cons-after
- 'install 'generate-full-cache
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((loaders-directory
- (string-append (assoc-ref outputs "out")
- "/lib/gdk-pixbuf-2.0/2.10.0/loaders")))
- (zero?
- (system
- (string-append
- "gdk-pixbuf-query-loaders "
- loaders-directory "/libpixbufloader-svg.so "
- (string-join (find-files (assoc-ref inputs "gdk-pixbuf")
- "libpixbufloader-.*\\.so") " ")
- "> " loaders-directory ".cache")))))
- %standard-phases))))
+ "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n")))
+ %standard-phases)))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib" ,glib "bin") ; glib-mkenums, etc.
@@ -1627,18 +1613,6 @@ engineering.")
`(("intltool" ,intltool)
("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
- (arguments
- `(#:phases
- (alist-cons-before
- 'build 'use-full-cache
- ;; Use librsvg's loaders.cache instead of the one provided by
- ;; gdk-pixbuf because the latter does not include support for SVG
- ;; files.
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "GDK_PIXBUF_MODULE_FILE"
- (car (find-files (assoc-ref inputs "librsvg")
- "loaders\\.cache"))))
- %standard-phases)))
(home-page "https://launchpad.net/gnome-themes-standard")
(synopsis "Default GNOME 3 themes")
(description