aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-04-03 12:52:37 +0200
committerLeo Famulari <leo@famulari.name>2016-05-15 13:03:15 -0400
commit9365ee1c464b1a4bda5325b9c5a16f9c09029d2a (patch)
treee9c4e01e150aff4b6d9bd9b6e06c1d6a43f06805 /gnu/packages/gnome.scm
parent277a7d82b84c0b9ae86a9466479c34548209b0bf (diff)
downloadguix-9365ee1c464b1a4bda5325b9c5a16f9c09029d2a.tar
guix-9365ee1c464b1a4bda5325b9c5a16f9c09029d2a.tar.gz
gnu: Add gnome-tweak-tool.
* gnu/packages/patches/gnome-tweak-tool-search-paths.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (gnome-tweak-tool): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6b78d0f720..8963e3fca6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5024,3 +5024,46 @@ specified duration and save it as a GIF encoded animated image file.")
"Libzapojit is a GLib-based library for accessing online service APIs of
Microsoft SkyDrive and Hotmail, using their REST protocols.")
(license license:lgpl2.1+)))
+
+(define-public gnome-tweak-tool
+ (package
+ (name "gnome-tweak-tool")
+ (version "3.20.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/gnome-tweak-tool/"
+ (version-major+minor version) "/"
+ "gnome-tweak-tool-" version ".tar.xz"))
+ (patches (list
+ (search-patch "gnome-tweak-tool-search-paths.patch")))
+ (sha256
+ (base32
+ "1fj6wjvnjygzm9br3sw9gya6d18yly1rm69yaiar9spfbkvv4wai"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--localstatedir=/tmp"
+ "--sysconfdir=/tmp")
+ #:imported-modules ((guix build python-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (@@ (guix build python-build-system) wrap)))))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("python" ,python-2)
+ ("python2-pygobject" ,python2-pygobject)))
+ (propagated-inputs
+ `(("libnotify" ,libnotify)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)))
+ (synopsis "Customize advanced GNOME 3 options")
+ (home-page "https://wiki.gnome.org/action/show/Apps/GnomeTweakTool")
+ (description
+ "GNOME Tweak Tool allows adjusting advanced configuration settings in
+GNOME 3. This includes things like the fonts used in user interface elements,
+alternative user interface themes, changes in window management behavior,
+GNOME Shell appearance and extension, etc.")
+ (license license:gpl3+)))