aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-04-15 22:06:05 -0400
committerLeo Famulari <leo@famulari.name>2016-06-15 13:18:31 -0400
commit6064a4e84af8ab1d799b687a63965ce7eef80af2 (patch)
treec318fcfec9395225cd524ae18da1de4dda8eaeb3 /gnu/packages/gnome.scm
parenta73c1cf84aa1cf06b0aeb49214fe762be53a97c1 (diff)
downloadguix-6064a4e84af8ab1d799b687a63965ce7eef80af2.tar
guix-6064a4e84af8ab1d799b687a63965ce7eef80af2.tar.gz
gnu: Add folks.
* gnu/packages/gnome.scm (folks): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 8a066ea2ba..e236e40e36 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5311,3 +5312,38 @@ style of the Arc GTK theme. Icons missing from the Arc theme are provided by
the Moka icon theme.")
(home-page "https://github.com/horst3180/arc-icon-theme")
(license license:gpl3+)))
+
+(define-public folks
+ (package
+ (name "folks")
+ (version "0.11.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1f51albxgfqxbax57i3pcgv2fx7i419xaapzdvldas6gw100ma1m"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs
+ `(("bdb" ,bdb)
+ ("dbus-glib" ,dbus-glib)
+ ("evolution-data-server" ,evolution-data-server)
+ ("glib" ,glib)
+ ("libgee" ,libgee)
+ ("telepathy-glib" ,telepathy-glib)))
+ (native-inputs
+ `(("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (synopsis "Library to aggregate data about people")
+ (description "Libfolks is a library that aggregates information about people
+from multiple sources (e.g., Telepathy connection managers for IM contacts,
+Evolution Data Server for local contacts, libsocialweb for web service contacts,
+etc.) to create metacontacts. It's written in Vala, which generates C code when
+compiled.")
+ (home-page "https://wiki.gnome.org/Projects/Folks")
+ (license license:lgpl2.1+)))