aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-01-16 10:50:18 +0000
committerChristopher Baines <mail@cbaines.net>2021-01-16 11:13:11 +0000
commit540893a8ccef41436a1c00ae268f74219f9ab220 (patch)
tree66ec2ed06262fc60da270e02ec65960598346d6b /gnu/packages/gnome.scm
parentb52bf667394991affcfba77bc72ed3d6e0b4d540 (diff)
downloadguix-540893a8ccef41436a1c00ae268f74219f9ab220.tar
guix-540893a8ccef41436a1c00ae268f74219f9ab220.tar.gz
gnu: gnome-font-viewer: Fix thumbnail generation.
Previously, thumbnail generation failed, as the gnome-thumbnail-font command couldn't be found. Using an absolute filename in the .thumbnailer file fixes this. Cached failures within .cache/thumbnails/fail/ or similar may need removing before the effect of this change can be seen. * gnu/packages/gnome.scm (gnome-font-viewer)[arguments]: Add patch-thumbnailer phase.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f4a98ab266..e00f65a32a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2252,6 +2252,16 @@ and keep up to date translations of documentation.")
(lambda _
(substitute* "meson-postinstall.sh"
(("update-desktop-database") (which "true")))
+ #t))
+ (add-after 'install 'patch-thumbnailer
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute*
+ (string-append
+ out
+ "/share/thumbnailers/gnome-font-viewer.thumbnailer")
+ (("gnome-thumbnail-font")
+ (string-append out "/bin/gnome-thumbnail-font"))))
#t)))))
(native-inputs
`(("gettext" ,gettext-minimal)