aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-14 13:29:58 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-20 13:01:47 +0800
commitea57378f242a2c768691ff49dc1c6f7c53281587 (patch)
treecdf44a0c8a83dbea197bc9ded702160c15689221 /gnu/packages/gnome.scm
parent24d56899a1fd329f2edf2c3d32d82ce7c158ace1 (diff)
downloadguix-ea57378f242a2c768691ff49dc1c6f7c53281587.tar
guix-ea57378f242a2c768691ff49dc1c6f7c53281587.tar.gz
gnu: Add vte.
* gnu/packages/gnome.scm (vte, vte/gtk+-2): New variables.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm57
1 files changed, 56 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5d84f4e411..d9a22b41bb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -47,7 +47,8 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages compression)
#:use-module (gnu packages xorg)
- #:use-module (gnu packages xdisorg))
+ #:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages ncurses))
(define-public brasero
(package
@@ -1324,3 +1325,57 @@ language features to GNOME developers without imposing any additional runtime
requirements and without using a different ABI compared to applications and
libraries written in C.")
(license license:lgpl2.1+)))
+
+(define-public vte
+ (package
+ (name "vte")
+ (version "0.38.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1rbxrigff9yszbgdw0gw4c2saz4d1hbbpz21phzxx14w49wvmnmj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("vala" ,vala)
+ ("gobject-introspection" ,gobject-introspection)
+ ("glib" ,glib "bin") ; for glib-genmarshal, etc.
+ ("xmllint" ,libxml2)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+))) ; required by libvte-2.91.pc
+ (home-page "http://www.gnome.org/")
+ (synopsis "Virtual Terminal Emulator")
+ (description
+ "VTE is a library (libvte) implementing a terminal emulator widget for
+GTK+, and a minimal sample application (vte) using that. Vte is mainly used in
+gnome-terminal, but can also be used to embed a console/terminal in games,
+editors, IDEs, etc.")
+ (license license:lgpl2.1+)))
+
+;; stable version for gtk2, required by xfce4-terminal.
+(define-public vte/gtk+-2
+ (package (inherit vte)
+ (name "vte")
+ (version "0.28.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1bmhahkf8wdsra9whd3k5l5z4rv7r58ksr8mshzajgq2ma0hpkw6"))))
+ (arguments
+ '(#:configure-flags '("--disable-python")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("glib" ,glib "bin"))) ; for glib-genmarshal, etc.
+ (propagated-inputs
+ `(("gtk+" ,gtk+-2) ; required by libvte.pc
+ ("ncurses" ,ncurses))))) ; required by libvte.la