aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
commit426adbe82731b8b4968cad8d474545d3e8b55c65 (patch)
tree5fbc7f62c5bfa2e3a97c01c7974d119cf6400824 /gnu/packages/gnome.scm
parent1ddbd9fd71502c9332ca84a74734121c407a5708 (diff)
downloadguix-426adbe82731b8b4968cad8d474545d3e8b55c65.tar
guix-426adbe82731b8b4968cad8d474545d3e8b55c65.tar.gz
gnu: glib: Add "bin" output.
Fixes <http://bugs.gnu.org/17853>. * gnu/packages/glib.scm (glib)[outputs]: Add "bin". (gobject-introspection)[native-inputs]: New field. * gnu/packages/avahi.scm (avahi)[native-inputs]: Add glib:bin. * gnu/packages/gnome.scm (brasero, libgnome-keyring, evince, gsettings-desktop-schemas, libnotify, gtkglext): Likewise. * gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base, gst-plugins-base-0.10): Likewise. * gnu/packages/gtk.scm (atk, pango, gdk-pixbuf, gtk+-2, gtk+): Likewise. * gnu/packages/linux.scm (udev): Likewise. * gnu/packages/pdf.scm (poppler): Likewise.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ee7c7c5ab1..dd407c5eeb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -60,6 +60,7 @@
`(("hicolor-icon-theme" ,hicolor-icon-theme)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)))
(inputs
`(("glib" ,glib)
@@ -73,9 +74,6 @@
("libnotify" ,libnotify)
("libsm" ,libsm)
("libxml2" ,libxml2)))
- (native-inputs
- `(("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/brasero/")
(synopsis "CD/DVD burning tool for Gnome")
(description "Brasero is an application to burn CD/DVD for the Gnome
@@ -173,6 +171,7 @@ and keep up to date translations of documentation.")
("dbus" ,dbus)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("intltool" ,intltool)))
(propagated-inputs
;; Referred to in .h files and .pc.
@@ -239,6 +238,7 @@ and keep up to date translations of documentation.")
("dogtail" ,python2-dogtail)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page
"http://www.gnome.org/projects/evince/")
@@ -268,6 +268,7 @@ on the GNOME Desktop with a single simple application.")
`(("glib" ,glib)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)))
(home-page "https://launchpad.net/gsettings-desktop-schemas")
(synopsis
@@ -402,7 +403,8 @@ database is translated at Transifex.")
("gtk+" ,gtk+)
("libpng" ,libpng)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")))
(home-page "https://developer-next.gnome.org/libnotify/")
(synopsis
"GNOME desktop notification library")
@@ -465,7 +467,8 @@ the API")
("mesa" ,mesa)
("libx11" ,libx11)
("libxt" ,libxt)))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")))
(propagated-inputs `(("pangox-compat" ,pangox-compat)))
(home-page "https://projects.gnome.org/gtkglext")
(synopsis "OpenGL extension to GTK+.")