aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-03-13 09:33:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-03-13 19:40:09 +0100
commit3edce2c9f9b14c2cd49c54abc5abb6d651c2ed23 (patch)
tree32e651baaf3196dff521505df14d63b878919cf1 /gnu/packages/gnome.scm
parent482dbe6a1622dce33b1c4b83775a0e6c53008686 (diff)
downloadguix-3edce2c9f9b14c2cd49c54abc5abb6d651c2ed23.tar
guix-3edce2c9f9b14c2cd49c54abc5abb6d651c2ed23.tar.gz
gnu: libgnomeprint: adapt to newer freetype.
* gnu/packages/gnome.scm (freetype): Change "freetype" to "freetype2" in snippet.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 52be520df5..b547b81f43 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1089,7 +1089,14 @@ widgets built in the loading process.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "129ka3nn8gx9dlfry17ib79azxk45wzfv5rgqzw6dwx2b5ns8phm"))))
+ "129ka3nn8gx9dlfry17ib79azxk45wzfv5rgqzw6dwx2b5ns8phm"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Adapt to newer freetype. As the package is deprecated, there
+ ;; is no use in creating a patch and reporting it.
+ '(substitute* '("libgnomeprint/gnome-font-face.c"
+ "libgnomeprint/gnome-rfont.c")
+ (("freetype/") "freetype2/")))))
(build-system gnu-build-system)
(inputs
`(("popt" ,popt)