aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-19 15:24:59 +0200
commita7bc1588e6b8ad4a890d9cc884016f36f92f2e7d (patch)
tree284cc0af9edb74bfafad70b5a6fac9ad8b07b532 /gnu/packages/gnome.scm
parent8a502c3b60fdd5d8ee0b08e1c9d4c0d7fedc2fda (diff)
parentdf570bf271536399993b39e7ea2ea0452bb6cde4 (diff)
downloadguix-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar
guix-a7bc1588e6b8ad4a890d9cc884016f36f92f2e7d.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 40173d4616..f842c4bc79 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 David Craven <david@craven.ch>
@@ -1176,7 +1176,7 @@ XML/CSS rendering engine.")
(define-public libgsf
(package
(name "libgsf")
- (version "1.14.42")
+ (version "1.14.43")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -1184,7 +1184,7 @@ XML/CSS rendering engine.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1hhdz0ymda26q6bl5ygickkgrh998lxqq4z9i8dzpcvqna3zpzr9"))))
+ "05pf3h0dha3s20ddsrljbx7m94qyiqs5igwxx1ql0vlsdlylx50j"))))
(build-system gnu-build-system)
(native-inputs
`(("intltool" ,intltool)
@@ -4177,7 +4177,11 @@ a secret password store, an adblocker, and a modern UI.")
;; subsystem
;; FAIL
'(#:tests? #f
- #:glib-or-gtk? #t))
+ #:glib-or-gtk? #t
+ #:configure-flags
+ ;; Otherwise, the RUNPATH will lack the final 'epiphany' path component.
+ (list (string-append "-Dc_link_args=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib/epiphany"))))
(propagated-inputs
`(("dconf" ,dconf)))
(native-inputs