aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-03-07 02:17:22 -0500
committerLeo Famulari <leo@famulari.name>2016-06-15 13:18:31 -0400
commit01ea778f68971a4d918cf28dc17559002c345288 (patch)
tree82a97d37138583fbdd1345bc4ec75e32a1774fa3 /gnu/packages/gnome.scm
parentf7c6833f1cc178b399b19a7109ec49f2b87c0ea0 (diff)
downloadguix-01ea778f68971a4d918cf28dc17559002c345288.tar
guix-01ea778f68971a4d918cf28dc17559002c345288.tar.gz
gnu: Add gfbgraph.
* gnu/packages/gnome.scm (gfbgraph): New variable.
Diffstat (limited to 'gnu/packages/gnome.scm')
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7660020662..74c4be6e24 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5353,3 +5353,36 @@ etc.) to create metacontacts. It's written in Vala, which generates C code when
compiled.")
(home-page "https://wiki.gnome.org/Projects/Folks")
(license license:lgpl2.1+)))
+
+(define-public gfbgraph
+ (package
+ (name "gfbgraph")
+ (version "0.2.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1dp0v8ia35fxs9yhnqpxj3ir5lh018jlbiwifjfn8ayy7h47j4fs"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:tests? #f ; Tests appear to require the network.
+ ;; FIXME --enable-gtk-doc fails even with gtk-doc as a native-input.
+ #:configure-flags '("--disable-gtk-doc"
+ "--disable-static"
+ "--enable-introspection")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("gobject-introspection" ,gobject-introspection)))
+ (inputs
+ `(("json-glib" ,json-glib)
+ ("gnome-online-accounts" ,gnome-online-accounts)
+ ("rest" ,rest)))
+ (synopsis "GLib/GObject wrapper for the Facebook API")
+ (description "This library allows you to use the Facebook API from
+GLib/GObject code.")
+ (home-page "https://wiki.gnome.org/Projects/GFBGraph")
+ (license license:lgpl2.1+)))