aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gnome-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-18 19:14:45 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-18 19:19:42 +0200
commit1066a424dc083b02d4f7a16316a7d223fd64aa6c (patch)
tree132b70c18cfae5059a2406fe51db68161988ace3 /gnu/packages/gnome-xyz.scm
parent98660657147be976b84e753be84b60dba1fac925 (diff)
downloadguix-1066a424dc083b02d4f7a16316a7d223fd64aa6c.tar
guix-1066a424dc083b02d4f7a16316a7d223fd64aa6c.tar.gz
gnu: gnome-shell-extension-noannoyance: Update to 16-1-b759d10f.
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-noannoyance): Update to 16-1-b759d10f.
Diffstat (limited to 'gnu/packages/gnome-xyz.scm')
-rw-r--r--gnu/packages/gnome-xyz.scm44
1 files changed, 24 insertions, 20 deletions
diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 429ede8650..4d53593944 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -714,27 +714,31 @@ into a single panel, similar to that found in KDE Plasma and Windows 7+.")
(license license:gpl2+)))
(define-public gnome-shell-extension-noannoyance
- (package
- (name "gnome-shell-extension-noannoyance")
- (version "5")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/BjoernDaase/noannoyance")
- (commit "e37b5b3c31f577b4698bc6659bc9fec5ea9ac5d4")))
- (sha256
- (base32
- "0fa8l3xlh8kbq07y4385wpb908zm6x53z81q16xlmin97dln32hh"))
- (file-name (git-file-name name version))))
- (build-system copy-build-system)
- (arguments
- '(#:install-plan
- '(("." "share/gnome-shell/extensions/noannoyance@daase.net"))))
- (synopsis "Remove 'Window is ready' annotation")
- (description "One of the many extensions that remove this message.
+ (let ((revision "1")
+ (commit "b759d10fd2799bc084007fdd927b62637c3dbd2c"))
+ (package
+ (name "gnome-shell-extension-noannoyance")
+ ;; XXX: There is no version noted anywhere in the source. Thus, infer it
+ ;; from <https://extensions.gnome.org/extension/2182/noannoyance/>.
+ (version (git-version "16" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bdaase/noannoyance")
+ (commit commit)))
+ (sha256
+ (base32
+ "0hh7fdqvx54h9j41ia2jl0nq1d5i66k7blw41ya6hkh7201r4anp"))
+ (file-name (git-file-name name version))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan
+ '(("." "share/gnome-shell/extensions/noannoyance@daase.net"))))
+ (synopsis "Remove 'Window is ready' annotation")
+ (description "One of the many extensions that remove this message.
It uses ES6 syntax and claims to be more actively maintained than others.")
- (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
- (license license:gpl2)))
+ (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
+ (license license:gpl2))))
(define-public gnome-shell-extension-paperwm
(package