aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-10-25 08:30:58 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-25 10:49:38 +0200
commitfc4083c54f603f9a4d593661641e88cfae0c35d1 (patch)
tree646da087f984018ea3583d1752d89ac55c70b1ba /gnu/packages/glib.scm
parenta372c4da2f6a96f4aeec99e3b43533eed33740d3 (diff)
downloadguix-fc4083c54f603f9a4d593661641e88cfae0c35d1.tar
guix-fc4083c54f603f9a4d593661641e88cfae0c35d1.tar.gz
gnu: Add perl-net-dbus-glib.
* gnu/packages/glib.scm (perl-net-dbus-glib): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index bc12a3616d..8e799718f7 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -66,7 +66,8 @@
libsigc++
glibmm
telepathy-glib
- perl-net-dbus))
+ perl-net-dbus
+ perl-net-dbus-glib))
(define dbus
(package
@@ -781,3 +782,29 @@ metadata.")
inter-application messaging system. The Perl API covers the core base level
of the DBus APIs, not concerning itself yet with the GLib or QT wrappers.")
(license license:perl-license)))
+
+(define perl-net-dbus-glib
+ (package
+ (name "perl-net-dbus-glib")
+ (version "0.33.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DANBERR/"
+ "Net-DBus-GLib-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1z4mbv8z0rad604xahijpg5szzi8qak07hbahh230z4jf96fkxvj"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus-glib" ,dbus-glib)))
+ (home-page "http://search.cpan.org/~danberr/Net-DBus-GLib-0.33.0/")
+ (synopsis "Perl extension for the DBus GLib bindings")
+ (description "This package provides an extension to the @code{Net::DBus}
+module allowing integration with the GLib mainloop. To integrate with the
+main loop, simply get a connection to the bus via the methods in
+@code{Net::DBus::GLib} rather than the usual @code{Net::DBus} module. Every
+other API remains the same.")
+ (license license:gpl2+)))