aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-09 15:07:16 -0500
committerLeo Famulari <leo@famulari.name>2017-03-09 15:20:01 -0500
commitbaa467762cd111cbc62adfb1dedcb82b3343c425 (patch)
treebdf2473f27b6665229566195aa72da73516439f1 /gnu/packages/glib.scm
parent24c72670d9d0efb3c88b40628cf2004eec200702 (diff)
downloadguix-baa467762cd111cbc62adfb1dedcb82b3343c425.tar
guix-baa467762cd111cbc62adfb1dedcb82b3343c425.tar.gz
gnu: glib: Avoid failing test caused by changes in the time zone database.
* gnu/packages/glib.scm (glib)[arguments]: Skip a failing test in 'disable-failing-tests' phase.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 74905004ef..45f4631f9f 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -246,7 +246,12 @@ shared NFS home directories.")
("gio/tests/gdbus-unix-addresses.c"
(;; Requires /etc/machine-id.
- "/gdbus/x11-autolaunch")))))
+ "/gdbus/x11-autolaunch"))
+
+ ("glib/tests/gdatetime.c"
+ (;; Assumes that the Brasilian time zone is named 'BRT',
+ ;; which is no longer true as of tzdata-2017a.
+ "/GDateTime/new_full")))))
(and-map (lambda (x) (apply disable x)) failing-tests)))))
;; Note: `--docdir' and `--htmldir' are not honored, so work around it.