aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-10-01 09:58:33 +0800
committer宋文武 <iyzsong@gmail.com>2015-10-14 21:25:33 +0800
commit25087f60b67e6031583cff2f4ac10873bf3d5520 (patch)
tree51d4d6bce8a63b592bdcc1750b434403907c32f5 /gnu/packages/glib.scm
parent53b5856ac1b19a6e7c74f781b1f14bf37965a8a4 (diff)
downloadguix-25087f60b67e6031583cff2f4ac10873bf3d5520.tar
guix-25087f60b67e6031583cff2f4ac10873bf3d5520.tar.gz
gnu: dbus: Drop patch.
* gnu/packges/patches/dbus-localstatedir.patch: Remove file. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/glib.scm (dbus): Remove patch. [argumests]: Remove 'post-install' phase. Don't create localestatedir and sysconfdir in the 'install' phase.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm64
1 files changed, 33 insertions, 31 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index c223b56096..a34d8f8776 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -59,39 +59,41 @@
(name "dbus")
(version "1.10.0")
(source (origin
- (method url-fetch)
- (uri
- (string-append "http://dbus.freedesktop.org/releases/dbus/dbus-"
- version ".tar.gz"))
- (sha256
- (base32
- "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))
- (patches (list (search-patch "dbus-localstatedir.patch")))))
+ (method url-fetch)
+ (uri (string-append
+ "http://dbus.freedesktop.org/releases/dbus/dbus-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jwj7wlrhq5y0fwfh8k2d9rgdpfax06lj8698g6iqbwrzd2rgyqx"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags (list ;; Install the system bus socket under /var.
- "--localstatedir=/var"
-
- ;; Look for configuration file under
- ;; /etc/dbus-1. This is notably required by
- ;; 'dbus-daemon-launch-helper', which looks for
- ;; the 'system.conf' file in that place,
- ;; regardless of what '--config-file' was
- ;; passed to 'dbus-daemon' on the command line;
- ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
- "--sysconfdir=/etc"
-
- "--with-session-socket-dir=/tmp")
- #:phases (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; 'dbus-launch' bails out if the 'session.d' directory
- ;; below is missing, so create it along with its companion.
- (let ((out (assoc-ref outputs "out")))
- (mkdir (string-append out "/etc/dbus-1/session.d"))
- (mkdir (string-append out "/etc/dbus-1/system.d"))
- #t))
- %standard-phases)))
+ '(#:configure-flags
+ (list
+ ;; Install the system bus socket under /var.
+ "--localstatedir=/var"
+
+ ;; Install the session bus socket under /tmp.
+ "--with-session-socket-dir=/tmp"
+
+ ;; Use /etc/dbus-1 for system-wide config.
+ ;; Look for configuration file under
+ ;; /etc/dbus-1. This is notably required by
+ ;; 'dbus-daemon-launch-helper', which looks for
+ ;; the 'system.conf' file in that place,
+ ;; regardless of what '--config-file' was
+ ;; passed to 'dbus-daemon' on the command line;
+ ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
+ "--sysconfdir=/etc")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'install
+ (lambda _
+ ;; Don't try to create /var and /etc.
+ (system* "make"
+ "localstatedir=/tmp/dummy"
+ "sysconfdir=/tmp/dummy"
+ "install"))))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs