aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-09-01 20:44:56 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-01 10:56:33 -0400
commit62a33ffc4395d5598c3d4141950287b0831a7887 (patch)
treea0cccc752b8605f07fa2d5b096dcc013db2cabea /gnu/packages/glib.scm
parent5f00e0363c194cd1f52eeb8da2417325af7c5acb (diff)
downloadguix-62a33ffc4395d5598c3d4141950287b0831a7887.tar
guix-62a33ffc4395d5598c3d4141950287b0831a7887.tar.gz
gnu: dbus-cxx: Update to 2.4.0.
* gnu/packages/glib.scm (dbus-cxx): Update to 2.4.0. [source]: Switch to git-fetch. [arguments]: Use g-exps. Adjust configure-flags. <phases>: Skip 'test-machine-uuid-method' test in check phase override. [inputs]: Add libcppgenerate. Remove python and glibmm. Move libsigc++ to... [propagated-inputs]: ...here. Add glib. [native-inputs]: Remove m4. [license]: Change to lgpl3+ and bsd-3. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm44
1 files changed, 28 insertions, 16 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index f523706449..e2a0bbdcdf 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -44,6 +44,7 @@
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages docbook)
#:use-module (gnu packages documentation)
#:use-module (gnu packages elf)
@@ -1255,26 +1256,37 @@ programming language. It also provides the @command{dbusxx-xml2cpp} and
(define-public dbus-cxx
(package
(name "dbus-cxx")
- (version "0.12.0")
+ (version "2.4.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/dbus-cxx/dbus-cxx/"
- version "/dbus-cxx-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dbus-cxx/dbus-cxx")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1acsgpkd9v7b9jdc79ijmh9dbdfrzgkwkaff518i3zpk7y6g5mzw"))))
+ "0c9q2bjs4m66zq0qysyip8fnkvvjpj46rkjcvw15nhmfhzbq16ag"))
+ (modules '((guix build utils)))
+ (snippet '(delete-file-recursively "tools/libcppgenerate"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DENABLE_TESTS=ON"
- "-DENABLE_TOOLS=ON"
- "-DENABLE_GLIBMM=ON")))
- (inputs (list dbus
- libsigc++
- glibmm
- python
- popt
- expat))
- (native-inputs (list pkg-config m4))
+ (list #:configure-flags #~(list "-DBUILD_TESTING=ON"
+ "-DENABLE_TOOLS=ON"
+ "-DENABLE_GLIB_SUPPORT=ON"
+ "-DTOOLS_BUNDLED_CPPGENERATE=OFF")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; There is no /etc/machine-id file in the build
+ ;; environment.
+ (invoke "ctest" "-E" "test-machine-uuid-method")))))))
+ ;; These are propagated due to being referenced in headers and pkg-config
+ ;; .pc files.
+ (propagated-inputs (list glib libsigc++))
+ (inputs (list dbus expat libcppgenerate popt))
+ (native-inputs (list pkg-config))
(synopsis "C++ wrapper for dbus")
(description "Dbus-cxx is a C++ wrapper for dbus.\n
It exposes the C API to allow direct manipulation and
@@ -1288,7 +1300,7 @@ This package provide 2 utils:
Some codes examples can be find at:
@url{https://dbus-cxx.github.io/examples.html}")
(home-page "https://dbus-cxx.github.io/")
- (license license:gpl3)))
+ (license (list license:lgpl3+ license:bsd-3)))) ;dual licensed
(define-public sdbus-c++
;; Use the latest commit, which includes unreleased fixes to the pkg-config