aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 10:11:29 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-07-23 10:11:29 +0200
commit4c204d01d57ac7da11a5772d5d4e3254d1c2408f (patch)
treec7e5cb013abc742734acd9613674df4ebddfdeef /gnu/packages/glib.scm
parent82bdb77082fa4e100761f70086b745dfb280c3ac (diff)
parent445a0359083388b5ee686e6e855f94a3aac5f79c (diff)
downloadguix-4c204d01d57ac7da11a5772d5d4e3254d1c2408f.tar
guix-4c204d01d57ac7da11a5772d5d4e3254d1c2408f.tar.gz
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm104
1 files changed, 103 insertions, 1 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 9400abe79a..935d8d4da1 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -14,7 +14,7 @@
;;; Copyright © 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
-;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2020 Arthur Margerit <ruhtra.mar@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -298,6 +298,108 @@ information, refer to the @samp{dbus-daemon(1)} man page.")))
(string-append "//" all "\n"))
(("^ g_assert_cmpfloat \\(elapsed, ==.*" all)
(string-append "//" all "\n"))))
+ '())
+ #$@(if (system-hurd?)
+ '((with-directory-excursion "gio/tests"
+ ;; TIMEOUT after 600s
+ (substitute* '("actions.c"
+ "dbus-appinfo.c"
+ "debugcontroller.c"
+ "gdbus-bz627724.c"
+ "gdbus-connection-slow.c"
+ "gdbus-exit-on-close.c"
+ "gdbus-export.c"
+ "gdbus-introspection.c"
+ "gdbus-method-invocation.c"
+ "gdbus-non-socket.c"
+ "gdbus-proxy-threads.c"
+ "gdbus-proxy-unique-name.c"
+ "gdbus-proxy-well-known-name.c"
+ "gdbus-proxy.c"
+ "gdbus-test-codegen.c"
+ "gmenumodel.c"
+ "gnotification.c"
+ "stream-rw_all.c")
+ (("return (g_test_run|session_bus_run)" all call)
+ (string-append "return 0;// " call))
+ ((" (ret|rtv|result) = (g_test_run|session_bus_run)"
+ all var call)
+ (string-append " " var " = 0;// " call))
+ (("[ \t]*g_test_add_func.*;") ""))
+
+ ;; commenting-out g_assert, g_test_add_func, g_test_run
+ ;; does not help; special-case short-circuit.
+ (substitute* "gdbus-connection-loss.c" ;; TODO?
+ ((" gchar \\*path;.*" all)
+ (string-append all " return 0;\n")))
+
+ ;; FAIL
+ (substitute* '("appmonitor.c"
+ "async-splice-output-stream.c"
+ "autoptr.c"
+ "contexts.c"
+ "converter-stream.c"
+ "file.c"
+ "g-file-info.c"
+ "g-file.c"
+ "g-icon.c"
+ "gapplication.c"
+ "gdbus-connection-flush.c"
+ "gdbus-connection.c"
+ "gdbus-names.c"
+ "gdbus-server-auth.c"
+ "gsocketclient-slow.c"
+ "gsubprocess.c"
+ "io-stream.c"
+ "live-g-file.c"
+ "memory-monitor.c"
+ "mimeapps.c"
+ "network-monitor-race.c"
+ "network-monitor.c"
+ "pollable.c"
+ "power-profile-monitor.c"
+ "readwrite.c"
+ "resources.c"
+ "socket-service.c"
+ "socket.c"
+ "tls-bindings.c"
+ "tls-certificate.c"
+ "tls-database.c"
+ "trash.c"
+ "vfs.c")
+ (("return (g_test_run|session_bus_run)" all call)
+ (string-append "return 0;// " call))
+ ((" (ret|rtv|result) = (g_test_run|session_bus_run)"
+ all var call)
+ (string-append " " var " = 0;// " call))
+ (("[ \t]*g_test_add_func.*;") ""))
+
+ ;; commenting-out g_test_add_func, g_test_run does
+ ;; not help; special-case short-circuit.
+ (substitute* "gsettings.c"
+ (("#ifdef TEST_LOCALE_PATH" all)
+ (string-append " return 0;\n" all)))
+
+ ;; commenting-out g_test_add_func, ;; g_test_run does
+ ;; not help; special-case short-circuit.
+ (substitute* "proxy-test.c"
+ ((" gint result.*;" all)
+ (string-append all " return 0;\n")))
+
+ ;; commenting-out g_test_add_func, g_test_run
+ ;; does not help; special-case short-circuit.
+ (substitute* "volumemonitor.c"
+ ((" gboolean ret;" all)
+ (string-append all " return 0;\n"))))
+
+ (with-directory-excursion "glib/tests"
+ ;; TIMEOUT after 600s
+ (substitute* "thread-pool.c"
+ (("[ \t]*g_test_add_func.*;") ""))
+
+ ;; FAIL
+ (substitute* "fileutils.c"
+ (("[ \t]*g_test_add_func.*;") ""))))
'())))
;; Python references are not being patched in patch-phase of build,
;; despite using python-wrapper as input. So we patch them manually.