aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/glib.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-22 00:25:03 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-22 00:26:11 +0200
commitda51f5bb010d8bfbdeaa63db5a54788da4adf9a2 (patch)
treef11320b6c7e1c0cd1ed97bd9b5f85591f1f2bc38 /gnu/packages/glib.scm
parent4a663ca4e8b5ded9a3d92870fba8f2ebde22d75a (diff)
downloadguix-da51f5bb010d8bfbdeaa63db5a54788da4adf9a2.tar
guix-da51f5bb010d8bfbdeaa63db5a54788da4adf9a2.tar.gz
gnu: dbus: Add variant with proper helper for service activation.
* gnu/packages/patches/dbus-helper-search-path.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/glib.scm (dbus/activation): New variable.
Diffstat (limited to 'gnu/packages/glib.scm')
-rw-r--r--gnu/packages/glib.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 6ef64e4b73..e4bf6ad0fc 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -59,6 +59,7 @@
(name "dbus")
(version "1.10.0")
(source (origin
+ ;; TODO: Apply patch from DBUS/ACTIVATION below.
(method url-fetch)
(uri (string-append
"http://dbus.freedesktop.org/releases/dbus/dbus-"
@@ -123,6 +124,17 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
shared NFS home directories.")
(license license:gpl2+))) ; or Academic Free License 2.1
+(define-public dbus/activation
+ ;; D-Bus with a patch to fix service activation.
+ ;; TODO: Merge with DBUS above.
+ (package
+ (inherit dbus)
+ (version (string-append (package-version dbus) ".a"))
+ (source (origin
+ (inherit (package-source dbus))
+ (patches
+ (list (search-patch "dbus-helper-search-path.patch")))))))
+
(define glib
(package
(name "glib")