aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-04-03 21:16:54 +0530
committerLudovic Courtès <ludo@gnu.org>2017-04-08 15:23:41 +0200
commit725d8d2c0845d2da5f2e9a7d01841d405d2b1fd6 (patch)
tree7ea591fa1e342f2a19f02842726acf242fa9a516 /gnu/packages/gl.scm
parent8bc2183fe54487793e9eb6b39ba01329671840b9 (diff)
downloadguix-725d8d2c0845d2da5f2e9a7d01841d405d2b1fd6.tar
guix-725d8d2c0845d2da5f2e9a7d01841d405d2b1fd6.tar.gz
gnu: Add gl2ps.
* gnu/packages/gl.scm (gl2ps): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 37a1bd9098..db708308d5 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -27,12 +28,14 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages documentation)
#:use-module (gnu packages flex)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gettext)
#:use-module (gnu packages guile)
+ #:use-module (gnu packages image)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages pkg-config)
@@ -612,3 +615,35 @@ library for OpenGL. It has lean API modeled after HTML5 canvas API. It is
aimed to be a practical and fun toolset for building scalable user interfaces
and visualizations.")
(license license:zlib)))
+
+(define-public gl2ps
+ (package
+ (name "gl2ps")
+ (version "1.3.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://geuz.org/gl2ps/src/gl2ps-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0h1nrhmkc4qjw2ninwpj2zbgwhc0qg6pdhpsibbvry0d2bzhns4a"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("libpng" ,libpng)
+ ("mesa" ,mesa)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:tests? #f)) ;; no tests
+ (home-page "http://www.geuz.org/gl2ps/")
+ (synopsis "OpenGL to PostScript printing library")
+ (description "GL2PS is a C library providing high quality vector
+output for any OpenGL application. GL2PS uses sorting algorithms
+capable of handling intersecting and stretched polygons, as well as
+non-manifold objects. GL2PS provides many features including advanced
+smooth shading and text rendering, culling of invisible primitives and
+mixed vector/bitmap output.")
+ (license (list license:lgpl2.0+
+ (license:fsf-free "http://www.geuz.org/gl2ps/COPYING.GL2PS"
+ "GPL-incompatible copyleft license")))))