aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-12-19 01:42:40 +0100
commit32cd878be0bb7e153fcaa6f3bfa2632867390ff9 (patch)
treefc1ff93949817c9d172c84d0410ac9225cad57ae /gnu/packages/gl.scm
parent753425610274ccb59cce13490c096027c61621d0 (diff)
parent98bd11cfe7b931e9c6d6bf002a8a225fb7a1025b (diff)
downloadguix-32cd878be0bb7e153fcaa6f3bfa2632867390ff9.tar
guix-32cd878be0bb7e153fcaa6f3bfa2632867390ff9.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1956f60e6e..62e272b5bf 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -41,6 +42,7 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xml)
@@ -724,3 +726,36 @@ mixed vector/bitmap output.")
(license (list license:lgpl2.0+
(license:fsf-free "http://www.geuz.org/gl2ps/COPYING.GL2PS"
"GPL-incompatible copyleft license")))))
+
+(define-public virtualgl
+ (package
+ (name "virtualgl")
+ (version "2.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/VirtualGL/virtualgl/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rnid3hwrry9d5d4m7sygq00xxx976rgk00a3557m9r5kxbmy476"))))
+ (arguments
+ `(#:tests? #f ;; no tests are available
+ #:configure-flags (list "-DVGL_USESSL=1" ;; use OpenSSL
+ (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out") "/lib"))))
+ (build-system cmake-build-system)
+ (inputs `(("glu" ,glu)
+ ("libjpeg-turbo" ,libjpeg-turbo)
+ ("mesa" ,mesa)
+ ("openssl" ,openssl)))
+ (native-inputs `(("pkg-config", pkg-config)))
+ (home-page "https://www.virtualgl.org")
+ (synopsis "Redirects 3D commands from an OpenGL application onto a 3D
+graphics card")
+ (description "VirtualGL redirects the 3D rendering commands from OpenGL
+applications to 3D accelerator hardware in a dedicated server and displays the
+rendered output interactively to a thin client located elsewhere on the
+network.")
+ (license license:wxwindows3.1+)))