aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-29 22:31:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-29 22:43:49 +0100
commit872ea4eb69d16c6d34f31e6cbe91f59e1aa06cba (patch)
tree84c6de24002cb39a60b348e88180b159cc1a04ed /gnu/packages/gl.scm
parent6f6f9267b6a2b5f70ce376d2268cf138782831a3 (diff)
downloadguix-872ea4eb69d16c6d34f31e6cbe91f59e1aa06cba.tar
guix-872ea4eb69d16c6d34f31e6cbe91f59e1aa06cba.tar.gz
gnu: s2tc: Fetch sources from git.
* gnu/packages/gl.scm (s2tc)[source]: Fetch from git.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 11c89b3d88..c724fff5f2 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -49,6 +49,7 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system cmake)
@@ -177,12 +178,13 @@ Polygon meshes, and Extruded polygon meshes.")
(version "1.0")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/divVerent/s2tc/archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/divVerent/s2tc.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0ibfdib277fhbqvxzan0bmglwnsl1y1rw2g8skvz82l1sfmmn752"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "1fg323fk7wlv2xh6lw66wswgcv6qi8aaadk7c28h2f2lj1s7njnf"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)