aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-29 14:03:59 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-29 14:04:27 +0200
commitfcc1e6760d5bb980cb3b858e3534033d74e3c9b4 (patch)
treec97b7398d31a9be09acd5dd1b10d9c21b241a12f /gnu/packages/gl.scm
parentb2419613d0a5605acf674e8ffc600448aa971008 (diff)
downloadguix-fcc1e6760d5bb980cb3b858e3534033d74e3c9b4.tar
guix-fcc1e6760d5bb980cb3b858e3534033d74e3c9b4.tar.gz
gnu: mesa: Add pl111 driver support for aarch64.
* gnu/packages/gl.scm (mesa)[arguments]: Build the pl111 gallium driver.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index f41251ce08..53de580e3d 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -279,7 +279,7 @@ also known as DXTn or DXTC) for Mesa.")
'("--with-gallium-drivers=freedreno,nouveau,r300,r600,swrast,vc4,virgl"))
("aarch64-linux"
;; TODO: Fix svga driver for aarch64 and armhf.
- '("--with-gallium-drivers=freedreno,nouveau,r300,r600,swrast,vc4,virgl"))
+ '("--with-gallium-drivers=freedreno,nouveau,pl111,r300,r600,swrast,vc4,virgl"))
(_
'("--with-gallium-drivers=i915,nouveau,r300,r600,radeonsi,svga,swrast,virgl")))
;; Enable various optional features. TODO: opencl requires libclc,