aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gl.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-11 21:49:24 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-03-19 10:00:15 +0100
commitb021a2adeb282869691d4b919a7337bfc859e414 (patch)
tree4381e3983faa48b704a63e8ee191bc2ed49cc6d4 /gnu/packages/gl.scm
parent0704788109865deda0f4219c6969d868a9ae45c3 (diff)
downloadguix-b021a2adeb282869691d4b919a7337bfc859e414.tar
guix-b021a2adeb282869691d4b919a7337bfc859e414.tar.gz
gnu: Add s2tc.
* gnu/packages/gl.scm (s2tc): New variable. (mesa-headers): New variable.
Diffstat (limited to 'gnu/packages/gl.scm')
-rw-r--r--gnu/packages/gl.scm52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7d549d38e5..e5d3a8d943 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -26,6 +26,7 @@
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (guix packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages bison)
#:use-module (gnu packages flex)
#:use-module (gnu packages pkg-config)
@@ -123,6 +124,38 @@ rendering modes are: Bitmaps, Anti-aliased pixmaps, Texture maps, Outlines,
Polygon meshes, and Extruded polygon meshes")
(license l:x11)))
+(define-public s2tc
+ (package
+ (name "s2tc")
+ (version "1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/divVerent/s2tc/archive/v" version ".tar.gz"))
+ (sha256
+ (base32 "0ibfdib277fhbqvxzan0bmglwnsl1y1rw2g8skvz82l1sfmmn752"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (inputs
+ `(("mesa-headers" ,mesa-headers)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after unpack autogen
+ (lambda _
+ (zero? (system* "sh" "autogen.sh")))))))
+ (home-page "https://github.com/divVerent/s2tc")
+ (synopsis "S3 Texture Compression implementation")
+ (description
+ "S2TC is a patent-free implementation of S3 Texture Compression (S3TC,
+also known as DXTn or DXTC) for Mesa.")
+ (license l:expat)))
+
(define-public mesa
(package
(name "mesa")
@@ -196,6 +229,25 @@ allows Mesa to be used in many different environments ranging from software
emulation to complete hardware acceleration for modern GPUs.")
(license l:x11)))
+(define-public mesa-headers
+ (package
+ (inherit mesa)
+ (name "mesa-headers")
+ (propagated-inputs '())
+ (inputs '())
+ (native-inputs '())
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete configure)
+ (delete build)
+ (delete check)
+ (replace install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (copy-recursively "include" (string-append
+ (assoc-ref outputs "out")
+ "/include")))))))))
+
(define-public glew
(package
(name "glew")