aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-08 17:43:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-08 18:43:05 +0300
commit3616ff51b33b94c388413f9a2790cab7bbbe8e72 (patch)
treef142363c0225080daac9523eb5bc4b80a209ac3c /gnu/packages/gimp.scm
parentb0a21b56db6c0e0db3cf5183509f860bae697712 (diff)
downloadguix-3616ff51b33b94c388413f9a2790cab7bbbe8e72.tar
guix-3616ff51b33b94c388413f9a2790cab7bbbe8e72.tar.gz
gnu: gegl: Use 'modify-phases' syntax.
* gnu/packages/gimp.scm (gegl)[arguments]: Use the 'modify-phases' syntax.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 40f39b29aa..cf9038c0a6 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -83,27 +83,27 @@ provided as well as the framework to add new color models and data types.")
(patches (search-patches "gegl-CVE-2012-4433.patch"))))
(build-system gnu-build-system)
(arguments
- `(;; More than just the one test disabled below now fails; disable them
+ '(;; More than just the one test disabled below now fails; disable them
;; all according to the rationale given below.
#:tests? #f
#:configure-flags '("LDFLAGS=-lm")
#:phases
- (alist-cons-before
- 'build 'pre-build
- (lambda _
- ;; This test program seems to crash on exit. Specifically, whilst
- ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
- ;; in the destructor. This is just a test program so will not have
- ;; any wider effect, although might be hiding another problem.
- ;; According to advice received on irc.gimp.org#gegl although 0.2.0
- ;; is the latest released version, any bug reports against it will
- ;; be ignored. So we are on our own.
- (substitute* "tools/img_cmp.c"
- (("g_object_unref \\(buffer.\\);") ""))
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda _
+ ;; This test program seems to crash on exit. Specifically, whilst
+ ;; g_object_unreffing bufferA and bufferB - This seems to be a bug
+ ;; in the destructor. This is just a test program so will not have
+ ;; any wider effect, although might be hiding another problem.
+ ;; According to advice received on irc.gimp.org#gegl although 0.2.0
+ ;; is the latest released version, any bug reports against it will
+ ;; be ignored. So we are on our own.
+ (substitute* "tools/img_cmp.c"
+ (("g_object_unref \\(buffer.\\);") ""))
- (substitute* "tests/compositions/Makefile"
- (("/bin/sh") (which "sh"))))
- %standard-phases)))
+ (substitute* "tests/compositions/Makefile"
+ (("/bin/sh") (which "sh")))
+ #t)))))
(inputs
`(("babl" ,babl)
("glib" ,glib)