aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gimp.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-04-02 08:12:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-04-26 22:18:00 +0200
commit1d6c6af0e2196819160222a617682516966824f7 (patch)
tree1fcf1d6e2785d420ab96a030a091081de203e9b8 /gnu/packages/gimp.scm
parentc30a66dedba48d1e60d2b04b84c8dbcaa513c6f0 (diff)
downloadguix-1d6c6af0e2196819160222a617682516966824f7.tar
guix-1d6c6af0e2196819160222a617682516966824f7.tar.gz
gnu: Add gimp-fourier.
* gnu/packages/gimp.scm (gimp-fourier): New variable.
Diffstat (limited to 'gnu/packages/gimp.scm')
-rw-r--r--gnu/packages/gimp.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/gimp.scm b/gnu/packages/gimp.scm
index 00feb1c131..bd2794305b 100644
--- a/gnu/packages/gimp.scm
+++ b/gnu/packages/gimp.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,9 +20,11 @@
(define-module (gnu packages gimp)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix build-system gnu)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
@@ -157,3 +160,53 @@ retouching, composition and authoring. It supports all common image formats
as well as specialized ones. It features a highly customizable interface
that is extensible via a plugin system.")
(license license:gpl3+))) ; some files are lgplv3
+
+(define-public gimp-fourier
+ (package
+ (name "gimp-fourier")
+ (version "0.4.3-2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://registry.gimp.org/files/fourier-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1rpacyad678lqgxa3hh2n0zpg4azs8dpa8q079bqsl12812k9184"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-prefix
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; gimptool-2.0 does not allow us to install to any target
+ ;; directory.
+ (let ((target (string-append (assoc-ref outputs "out")
+ "/lib/gimp/"
+ (car (string-split ,(package-version gimp) #\.))
+ ".0/plug-ins")))
+ (substitute* "Makefile"
+ (("\\$\\(PLUGIN_INSTALL\\) fourier")
+ (string-append "cp fourier " target)))
+ (mkdir-p target))
+ #t)))))
+ (inputs
+ `(("fftw" ,fftw)
+ ("gimp" ,gimp)
+ ;; needed by gimp-2.0.pc
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("cairo" ,cairo)
+ ("glib" ,glib)
+ ;; needed by gimpui-2.0.pc
+ ("gtk+" ,gtk+-2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://registry.gimp.org/node/19596")
+ (synopsis "GIMP plug-in to edit image in fourier space")
+ (description
+ "This package provides a simple plug-in to apply the fourier transform on
+an image, allowing you to work with the transformed image inside GIMP. You
+can draw or apply filters in fourier space and get the modified image with an
+inverse fourier transform.")
+ (license license:gpl3+)))