aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-01-23 01:31:24 -0500
committerLeo Famulari <leo@famulari.name>2017-01-23 15:34:03 -0500
commit84b60a7cdfca1421a478894e279104a0c18a7c6d (patch)
tree475672118a0357e59afcd4cae6e71b68b15d79fb /gnu/packages/ghostscript.scm
parentbed2e0dfd1f21f00508bca5eac425e5f7c9feec1 (diff)
downloadguix-84b60a7cdfca1421a478894e279104a0c18a7c6d.tar
guix-84b60a7cdfca1421a478894e279104a0c18a7c6d.tar.gz
gnu: lcms: Fix an out-of-bounds read.
* gnu/packages/patches/lcms-fix-out-of-bounds-read.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ghostscript.scm (lcms)[replacement]: New field. [properties]: Specify the 'cpe-name'. (lcms/fixed): New variable.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 46b8c51299..a00448a8c6 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -39,6 +39,7 @@
(define-public lcms
(package
(name "lcms")
+ (replacement lcms/fixed)
(version "2.6")
(source (origin
(method url-fetch)
@@ -58,6 +59,14 @@ Consortium standard (ICC), approved as ISO 15076-1.")
(license license:x11)
(home-page "http://www.littlecms.com/")))
+(define lcms/fixed
+ (package
+ (inherit lcms)
+ (source
+ (origin
+ (inherit (package-source lcms))
+ (patches (search-patches "lcms-fix-out-of-bounds-read.patch"))))))
+
(define-public libpaper
(package
(name "libpaper")