aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ghostscript.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-14 14:47:37 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-01-19 12:38:42 +0100
commit01aae5fcce851d2cf9b6ee6683d38de7fa923a1c (patch)
tree6a087b1c97f4e6bc48e98b1c4db3ee214f692835 /gnu/packages/ghostscript.scm
parent7873318d301d5a44030f1604e0d27ab9d318eb9b (diff)
downloadguix-01aae5fcce851d2cf9b6ee6683d38de7fa923a1c.tar
guix-01aae5fcce851d2cf9b6ee6683d38de7fa923a1c.tar.gz
gnu: Add IJS
* gnu/packages/ghostscript.scm (ijs): New variable.
Diffstat (limited to 'gnu/packages/ghostscript.scm')
-rw-r--r--gnu/packages/ghostscript.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/ghostscript.scm b/gnu/packages/ghostscript.scm
index 405b4e744e..e2d4e618fa 100644
--- a/gnu/packages/ghostscript.scm
+++ b/gnu/packages/ghostscript.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,6 +20,7 @@
(define-module (gnu packages ghostscript)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages image)
@@ -164,6 +166,49 @@ output file formats and printers.")
(license license:agpl3+)
(home-page "http://www.gnu.org/software/ghostscript/")))
+(define-public ijs
+ (package
+ (name "ijs")
+ (version "9.14.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/ghostscript/gnu-ghostscript-"
+ version ".tar.xz"))
+ (sha256 (base32
+ "0q4jj41p0qbr4mgcc9q78f5zs8cm1g57wgryhsm2yq4lfslm3ib1"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("libtool" ,libtool)
+ ("automake" ,automake)
+ ("autoconf" ,autoconf)))
+ (arguments
+ `(#:phases
+ (alist-cons-after
+ 'unpack 'autogen
+ (lambda _
+ ;; need to regenerate macros
+ (system* "autoreconf" "-if")
+ ;; do not run configure
+ (substitute* "autogen.sh"
+ (("^.*\\$srcdir/configure.*") ""))
+ (system* "bash" "autogen.sh")
+
+ ;; create configure script in ./ijs/
+ (chdir "ijs")
+ ;; do not run configure
+ (substitute* "autogen.sh"
+ (("^.*\\$srcdir/configure.*") "")
+ (("^ + && echo Now type.*$") ""))
+ (zero? (system* "bash" "autogen.sh")))
+ %standard-phases)))
+ (synopsis "IJS driver framework for inkjet and other raster devices")
+ (description
+ "IJS is a protocol for transmission of raster page images. This package
+provides the reference implementation of the raster printer driver
+architecture.")
+ (license license:expat)
+ (home-page "http://www.gnu.org/software/ghostscript/")))
+
(define-public gs-fonts
(package
(name "gs-fonts")