aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2017-11-02 14:40:17 -0400
committerKei Kebreau <kkebreau@posteo.net>2017-11-02 14:42:58 -0400
commit67bd376b1a45249d0b1b1477e32638a984aebd70 (patch)
tree4e92f88d48ddde25248ef31e70e769672d8361e2 /gnu/packages/geo.scm
parent4dd137d50868cfe85c123644d247345c89f61cd8 (diff)
downloadguix-67bd376b1a45249d0b1b1477e32638a984aebd70.tar
guix-67bd376b1a45249d0b1b1477e32638a984aebd70.tar.gz
gnu: gnome-maps: Update to 3.26.2.
* gnu/packages/geo.scm (gnome-maps): Update to 3.26.2. [arguments]: In 'install' phase, add webkitgtk to LD_LIBRARY_PATH.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm34
1 files changed, 19 insertions, 15 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d8d5490f3e..7bf1562ba0 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -75,7 +75,7 @@ topology functions.")
(define-public gnome-maps
(package
(name "gnome-maps")
- (version "3.24.3")
+ (version "3.26.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -83,30 +83,34 @@ topology functions.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1mnhcrawdp6fyqylh0m8l259xdd7pqwibrjyl54rmsvnm8vfrwsy"))))
+ "0l40l7m9dyphvasiq1jxrn6ivavs1xwzn0bzz2x1z7x73955q783"))))
(build-system glib-or-gtk-build-system)
(arguments
- `(#:configure-flags ; Ensure that geoclue is referred to by output.
+ `(#:configure-flags ;; Ensure that geoclue is referred to by output.
(list (string-append "LDFLAGS=-L"
(assoc-ref %build-inputs "geoclue") "/lib")
(string-append "CFLAGS=-I"
(assoc-ref %build-inputs "geoclue") "/include"))
#:phases
(modify-phases %standard-phases
- (add-after
- 'install 'wrap
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
- (goa-path (string-append
+ (add-after 'install 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
+ (goa-path (string-append
(assoc-ref inputs "gnome-online-accounts")
- "/lib")))
- (wrap-program (string-append out "/bin/gnome-maps")
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
+ "/lib"))
+ (webkitgtk-path (string-append
+ (assoc-ref inputs "webkitgtk")
+ "/lib")))
+ (wrap-program (string-append out "/bin/gnome-maps")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
- ;; There seems to be no way to embed the path of libgoa-1.0.so.0.
- `("LD_LIBRARY_PATH" ":" prefix (,goa-path)))
- #t))))))
+ ;; There seems to be no way to embed the path of
+ ;; libgoa-1.0.so.0, libwebkit2gtk-4.0.so.37 and
+ ;; libjavascriptcoregtk-4.0.so.18.
+ `("LD_LIBRARY_PATH" ":" prefix (,goa-path ,webkitgtk-path)))
+ #t))))))
(native-inputs
`(("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)