aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2017-01-16 21:05:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-01-17 14:41:08 +0100
commit065d0125115cc952fa463d0542929ecbb3fd90f0 (patch)
tree827c2d52136a4bd7d9776aa45dfc14b340b36831 /gnu/packages/geo.scm
parentf68647299cf720f51e7c71c0e5b6d14d5e0030be (diff)
downloadguix-065d0125115cc952fa463d0542929ecbb3fd90f0.tar
guix-065d0125115cc952fa463d0542929ecbb3fd90f0.tar.gz
gnu: Add proj.4.
* gnu/packages/geo.scm (proj.4): New variable. (gnome-maps): Use license: prefix. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm56
1 files changed, 54 insertions, 2 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 86828e717d..797b9ea304 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2017 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19,8 +20,9 @@
(define-module (gnu packages geo)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix build-system gnu)
#:use-module (guix download)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (gnu packages glib)
@@ -92,4 +94,54 @@
the OpenStreetMap project. It can provide directions for walking, bicycling,
and driving.")
(home-page "https://wiki.gnome.org/Apps/Maps")
- (license gpl2+)))
+ (license license:gpl2+)))
+
+(define-public proj.4
+ (package
+ (name "proj.4")
+ (version "4.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.osgeo.org/proj/proj-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1xw5f427xk9p2nbsj04j6m5zyjlyd66sbvl2bkg8hd1kx8pm9139"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-test-paths
+ (lambda _
+ (substitute* '("nad/test27"
+ "nad/test83"
+ "nad/testvarious"
+ "nad/testdatumfile"
+ "nad/testflaky"
+ "nad/testIGNF")
+ (("/bin/rm") (which "rm")))
+ #t))
+ ;; Precision problems on i686 and other platforms. See:
+ ;; https://web.archive.org/web/20151006134301/http://trac.osgeo.org/proj/ticket/255
+ ;; Disable failing test.
+ (add-after 'patch-test-paths 'ignore-failing-tests
+ (lambda _
+ (substitute* '("nad/Makefile.in")
+ (("\tPROJ_LIB.*" all) (string-append "#" all)))
+ #t)))))
+ (inputs
+ `(("glib" ,glib)))
+ (home-page "http://proj4.org/")
+ (synopsis "Cartographic Projections Library")
+ (description
+ "Proj.4 is a library for converting coordinates between cartographic
+projections.")
+ (license (list license:expat
+ ;; src/PJ_patterson.c
+ license:asl2.0
+ ;; src/geodesic.c/h
+ license:x11
+ ;; Embedded EPSG database.
+ (license:non-copyleft "http://www.epsg.org/TermsOfUse")
+ ;; cmake/*
+ license:boost1.0))))