aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-02-17 16:31:41 -0500
committerLeo Famulari <leo@famulari.name>2018-03-15 10:57:50 -0400
commit9ddf42099b398d107467bc42bb495a20f502925f (patch)
tree5855a4902d74b37e7d956d98fe1c5d95115139af /gnu/packages/geo.scm
parentebc4bd5b54260082a2897669668144467b856198 (diff)
downloadguix-9ddf42099b398d107467bc42bb495a20f502925f.tar
guix-9ddf42099b398d107467bc42bb495a20f502925f.tar.gz
gnu: Add Rgooglemaps.
* gnu/packages/geo.scm (r-rgooglemaps): New variable.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e58342d62e..b6b185e5cb 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -533,3 +533,25 @@ coordinates.")
(license:non-copyleft ; The C code
"https://www.gnu.org/licenses/license-list.en.html#lucent102"
"Lucent Public License Version 1.02")))))
+
+(define-public r-rgooglemaps
+ (package
+ (name "r-rgooglemaps")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "RgoogleMaps" version))
+ (sha256
+ (base32
+ "0fsmlnhl4kw2j4972kfanzw9njhnzk695gsyw8g6yppsmz2clcaq"))))
+ (properties `((upstream-name . "RgoogleMaps")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-png" ,r-png)))
+ (home-page "https://cran.r-project.org/web/packages/RgoogleMaps")
+ (synopsis "Use Google Maps in R")
+ (description "This package serves two purposes: (i) Provide a comfortable R
+interface to query the Google server for static maps, and (ii) Use the map as a
+background image to overlay plots within R. This requires proper coordinate
+scaling.")
+ (license license:gpl2+)))