aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-23 08:44:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-23 21:18:21 +0100
commit8d26f48e8ab3802d73e74b18c877c549c4248eed (patch)
tree3fc2ec6899c8eb33c9716e21483f4269ee48c5b0 /gnu/packages/geo.scm
parent04ba7a9db6c956ae39b6bff0835b9d531e0c269c (diff)
downloadguix-8d26f48e8ab3802d73e74b18c877c549c4248eed.tar
guix-8d26f48e8ab3802d73e74b18c877c549c4248eed.tar.gz
gnu: gnome-maps: Add missing inputs.
* gnu/packages/geo.scm (gnome-maps)[inputs]: Add libsecret, libsoup, libgweather, gdk-pixbuf, glib-networking, and gsettings-desktop-schemas.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 5a24ed6146..9c7f7c1158 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2017 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,9 +73,6 @@ topology functions.")
license:zlib ; tests/xmltester/tinyxml/*
license:public-domain)))) ; include/geos/timeval.h
-;;; FIXME GNOME Maps only runs within GNOME. On i3, it fails with this error:
-;;; (org.gnome.Maps:8568): GLib-GIO-ERROR **: Settings schema
-;;; 'org.gnome.desktop.interface' is not installed
(define-public gnome-maps
(package
(name "gnome-maps")
@@ -122,13 +120,19 @@ topology functions.")
`(("folks" ,folks)
("libchamplain" ,libchamplain)
("libgee" ,libgee)
+ ("libsecret" ,libsecret)
+ ("libsoup" ,libsoup)
+ ("libgweather" ,libgweather)
("libxml2" ,libxml2)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("glib-networking" ,glib-networking)
("geoclue" ,geoclue)
("geocode-glib" ,geocode-glib)
("gfbgraph" ,gfbgraph)
("gjs" ,gjs)
("glib" ,glib)
("gnome-online-accounts" ,gnome-online-accounts)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("rest" ,rest)
("webkitgtk" ,webkitgtk)))
(propagated-inputs