aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorBjörn Höfling <bjoern.hoefling@bjoernhoefling.de>2017-07-20 17:50:18 +0200
committerArun Isaac <arunisaac@systemreboot.net>2018-01-04 12:15:29 +0530
commit1a39141dcf883a9a90fd7c67f94cf5f93c53cad6 (patch)
tree7e08f58e4c55b0caf769078527ca1f4f1e19b3fc /gnu/packages/geo.scm
parentcc8d346b9613b3b38ba2eaaecb1dcdf9dbaa068b (diff)
downloadguix-1a39141dcf883a9a90fd7c67f94cf5f93c53cad6.tar
guix-1a39141dcf883a9a90fd7c67f94cf5f93c53cad6.tar.gz
gnu: Add libgeotiff.
* gnu/packages/geo.scm (libgeotiff): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 7bf1562ba0..c3a62c6417 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -25,9 +25,11 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
+ #:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xml))
@@ -137,6 +139,55 @@ and driving.")
(home-page "https://wiki.gnome.org/Apps/Maps")
(license license:gpl2+)))
+(define-public libgeotiff
+ (package
+ (name "libgeotiff")
+ (version "1.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.osgeo.org/geotiff/libgeotiff/libgeotiff-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0vjy3bwfhljjx66p9w999i4mdhsf7vjshx29yc3pn5livf5091xd"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove .csv files, distributed from EPSG under a restricted
+ ;; license. See LICENSE for full license text.
+ (for-each delete-file (find-files "." "\\.csv$"))
+ ;; Now that we have removed the csv files, we need to modify the Makefile.
+ (substitute* "Makefile.in"
+ (("^all-am: .*$")
+ "all-am: Makefile $(LTLIBRARIES) $(HEADERS) geo_config.h\n")
+ (("^install-data-am: .*$")
+ "install-data-am: install-includeHEADERS"))))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libjpeg-turbo" ,libjpeg-turbo)
+ ("libtiff" ,libtiff)
+ ("proj.4" ,proj.4)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:configure-flags
+ (list (string-append "--with-zlib")
+ (string-append "--with-jpeg")
+ (string-append "--with-libtiff=" (assoc-ref %build-inputs "libtiff")))))
+ (synopsis "Library for handling GeoTIFF (geographic enabled TIFF)")
+ (description "libgeotiff is a library on top of libtiff for reading and
+writing GeoTIFF information tags.")
+ (home-page "https://trac.osgeo.org/geotiff/")
+ ;; This is a mixture of various contributions under different licenses.
+ ;; Note that the EPSG database is NOT "free to use" as the LICENSE file
+ ;; states, as its commercial redistribution is restricted. Hence, we have
+ ;; removed it from the package.
+ (license (list license:public-domain
+ license:x11
+ license:bsd-3
+ (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution.")))))
+
(define-public proj.4
(package
(name "proj.4")