aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/geo.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2019-12-05 01:46:28 +0530
committerArun Isaac <arunisaac@systemreboot.net>2019-12-26 18:54:42 +0530
commit1cbe7a3ed63f8bc9d752e0f608603ae072d70468 (patch)
treebd539eca815feb083da337d273e101473b693e48 /gnu/packages/geo.scm
parent75e2c054960e86983027b7fe0a3a77df4a91424c (diff)
downloadguix-1cbe7a3ed63f8bc9d752e0f608603ae072d70468.tar
guix-1cbe7a3ed63f8bc9d752e0f608603ae072d70468.tar.gz
gnu: libspatialindex: Update to 1.9.3.
* gnu/packages/geo.scm (libspatialindex): Update to 1.9.3. [build-system]: Switch to cmake-build-system. [source]: Update URI.
Diffstat (limited to 'gnu/packages/geo.scm')
-rw-r--r--gnu/packages/geo.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8023dcef26..0103202593 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1047,16 +1047,17 @@ volunteers.")
(define-public libspatialindex
(package
(name "libspatialindex")
- (version "1.8.5")
+ (version "1.9.3")
(source
(origin
(method url-fetch)
- (uri (string-append "https://download.osgeo.org/libspatialindex/"
- "spatialindex-src-" version ".tar.gz"))
+ (uri (string-append "https://github.com/libspatialindex/libspatialindex/"
+ "releases/download/" version "/spatialindex-src-"
+ version ".tar.bz2"))
(sha256
(base32
- "1vxzm7kczwnb6qdmc0hb00z8ykx11zk3sb68gc7rch4vrfi4dakw"))))
- (build-system gnu-build-system)
+ "02n5vjcyk04w0djidyp21hfbxfpbbara8ifd9nml6158rwqr8lja"))))
+ (build-system cmake-build-system)
(home-page "https://libspatialindex.org")
(synopsis "Spatial indexing library")
(description "The purpose of this library is to provide: