aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-31 01:18:34 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-31 01:20:30 +0100
commitec6ba5c1fe9308cbc18f06c99adcfe0d13396a18 (patch)
treed7de38666a9d6c32918835c9dd88369cf72ed1b0 /gnu/packages/gcc.scm
parentc99a64e15f19228ce03a683cae6e5b12d6bc1be3 (diff)
downloadguix-ec6ba5c1fe9308cbc18f06c99adcfe0d13396a18.tar
guix-ec6ba5c1fe9308cbc18f06c99adcfe0d13396a18.tar.gz
gnu: gcc: Fix cross-compilation to GNU/Hurd.
* gnu/packages/gcc.scm (gcc-configure-flags-for-triplet): Return "--disable-libcilkrts" when TARGET matches "-gnu".
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 7f4cf8ab69..8b0050d506 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -65,6 +65,14 @@ where the OS part is overloaded to denote a specific ABI---into GCC
"--with-mode=thumb"
"--with-fpu=neon"))
+ ((and (string-suffix? "-gnu" target)
+ (not (string-contains target "-linux")))
+ ;; Cross-compilation of libcilkrts in GCC 5.5.0 to GNU/Hurd fails
+ ;; with:
+ ;; libcilkrts/runtime/os-unix.c:388:2: error: #error "Unknown architecture"
+ ;; Cilk has been removed from GCC 8 anyway.
+ '("--disable-libcilkrts"))
+
(else
;; TODO: Add `arm.*-gnueabi', etc.
'())))