aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-02-19 19:21:06 +0000
committerLudovic Courtès <ludo@gnu.org>2017-04-13 14:40:48 +0200
commitbd54c5e3faa9fc46b00428be2f7a5e16afc64f5e (patch)
tree4c5d68af0eb9dabc32b60f5ccc8f4852dfb909e7 /gnu/packages/gcc.scm
parent480da86d0969a667e8d2a564de535cb73a6a2229 (diff)
downloadguix-bd54c5e3faa9fc46b00428be2f7a5e16afc64f5e.tar
guix-bd54c5e3faa9fc46b00428be2f7a5e16afc64f5e.tar.gz
gnu: gcc: Adjust for "alpha-linux".
This change allows cross-building packages by just using --target=alpha-unknown-linux-gnu re2c: $ ./pre-inst-env guix build --target=alpha-unknown-linux-gnu re2c $ file /gnu/store/p1z9iszzb4ng0vzc535sc2ha33ax24l6-re2c-0.16/bin/re2c /gnu/store/p1z9iszzb4ng0vzc535sc2ha33ax24l6-re2c-0.16/bin/re2c: \ ELF 64-bit LSB executable, Alpha (unofficial), version 1 (SYSV), dynamically linked, \ interpreter /gnu/store/0z5d6z3hh41w7z5g2g82zlnwgpbj0i1a-glibc-cross-alpha-unknown-linux-gnu-2.24/lib/ld-linux.so.2, \ for GNU/Linux 3.2.0, not stripped GCC for alpha uses 'GLIBC_DYNAMIC_LINKER<TAB>"/lib/ld-linux.so.2"' * gnu/packages/gcc.scm (gcc-4.7)[arguments]: Fix GLIBC_DYNAMIC_LINKER substitution when delimiter is a tab. Signed-off-by: Sergei Trofimovich <slyfox@inbox.ru> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 00e2fa7d66..0fdb5ca9b8 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -213,7 +213,7 @@ where the OS part is overloaded to denote a specific ABI---into GCC
;; Fix the dynamic linker's file name.
(substitute* (find-files "gcc/config"
"^(linux|gnu|sysv4)(64|-elf|-eabi)?\\.h$")
- (("#define (GLIBC|GNU_USER)_DYNAMIC_LINKER([^ ]*).*$"
+ (("#define (GLIBC|GNU_USER)_DYNAMIC_LINKER([^ \t]*).*$"
_ gnu-user suffix)
(format #f "#define ~a_DYNAMIC_LINKER~a \"~a\"~%"
gnu-user suffix