aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-09 20:45:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-06 11:34:46 +0200
commitb773e9b005fe0479f6504dcbb9d44d5a380de95e (patch)
tree3284817e3e5d507e045fc11080d2cc9dec6634df /gnu/packages/gcc.scm
parent74a2b2b43933201966e30eeeb58596a616df16bd (diff)
downloadguix-b773e9b005fe0479f6504dcbb9d44d5a380de95e.tar
guix-b773e9b005fe0479f6504dcbb9d44d5a380de95e.tar.gz
gnu: gcc: Force Aarch64 to use /lib.
* gnu/packages/gcc.scm (gcc)[arguments]: On aarch64 replace force libdir to be lib and not lib64.
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 075642ebd1..9376679f14 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -263,6 +263,12 @@ where the OS part is overloaded to denote a specific ABI---into GCC
(("static char const sed_cmd_z\\[\\] =.*;")
"static char const sed_cmd_z[] = \"sed\";"))
+ ;; Aarch64 support didn't land in GCC until the 4.8 series.
+ (when (file-exists? "gcc/config/aarch64")
+ ;; Force Aarch64 libdir to be /lib and not /lib64
+ (substitute* "gcc/config/aarch64/t-aarch64-linux"
+ (("lib64") "lib")))
+
(when (file-exists? "libbacktrace")
;; GCC 4.8+ comes with libbacktrace. By default it builds
;; with -Werror, which fails with a -Wcast-qual error in glibc