aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gcc.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2024-11-04 19:58:01 +0100
committerJanneke Nieuwenhuizen <janneke@gnu.org>2024-12-03 08:33:12 +0100
commitcb765c421846a79d9dae8f0c090cc7e0b85e8d88 (patch)
tree359f54c4e0e3b1173a9c766757672981522c8af3 /gnu/packages/gcc.scm
parent5f0a02a1902c5f9d37aa9c1e18828ffb7d4c16c9 (diff)
downloadguix-cb765c421846a79d9dae8f0c090cc7e0b85e8d88.tar
guix-cb765c421846a79d9dae8f0c090cc7e0b85e8d88.tar.gz
gnu: libstdc++: Support the 64bit Hurd.
* gnu/packages/gcc.scm (make-libstdc++)[arguments]: When building for the 64bit Hurd, add stage patch-hurd64. Change-Id: I795a591ef8282ee5b760fec43bd4ad849007f602
Diffstat (limited to 'gnu/packages/gcc.scm')
-rw-r--r--gnu/packages/gcc.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index c9e475b676..64ba37fd69 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -1024,7 +1024,15 @@ using compilers other than GCC."
(("/lib64") "/lib")))))
(add-before 'configure 'chdir
(lambda _
- (chdir "libstdc++-v3"))))
+ (chdir "libstdc++-v3")))
+ #$@(let ((version (package-version gcc)))
+ (if (target-hurd64?)
+ #~((add-after 'unpack 'patch-hurd64
+ (lambda _
+ (substitute* "libstdc++-v3/src/c++20/tzdb.cc"
+ (("#if ! defined _GLIBCXX_ZONEINFO_DIR")
+ "#if __GNU__ || ! defined _GLIBCXX_ZONEINFO_DIR")))))
+ '())))
#:configure-flags '`("--disable-libstdcxx-pch"
,(string-append "--with-gxx-include-dir="