aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/gawk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-10 11:09:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-10 11:21:43 +0200
commit78cd051eef9e25a6993478619d2bdb2db60565a6 (patch)
tree8db64edd2db48d4a069068b0053910c69c0cc7e2 /gnu/packages/gawk.scm
parent2ba2c98d8aa695cce608313833a36c61b0fb3428 (diff)
downloadguix-78cd051eef9e25a6993478619d2bdb2db60565a6.tar
guix-78cd051eef9e25a6993478619d2bdb2db60565a6.tar.gz
gnu: gawk: Update to 4.2.0.
* gnu/packages/gawk.scm (gawk): Update to 4.2.0.
Diffstat (limited to 'gnu/packages/gawk.scm')
-rw-r--r--gnu/packages/gawk.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index e318993ace..7828a4cd0e 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,13 +30,13 @@
(define-public gawk
(package
(name "gawk")
- (version "4.1.4")
+ (version "4.2.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gawk/gawk-" version
".tar.xz"))
(sha256
- (base32 "0rn2mmjxm767zliqzd67j7h2ncjn4j0321c60y9fy3grs3i89qak"))))
+ (base32 "1wm9lqj77y7xz07zi0n187aqm8zavzxzpm1j53ahxz81q0qwvwyl"))))
(build-system gnu-build-system)
(arguments
`(#:parallel-tests? #f ; test suite fails in parallel
@@ -56,7 +57,8 @@
'((substitute* "extension/Makefile.in"
(("^.*: check-for-shared-lib-support" match)
(string-append "### " match))))
- '()))))
+ '())
+ #t)))
(add-before 'check 'adjust-test-infrastructure
(lambda _