aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorng0 <ng0@pragmatique.xyz>2017-06-01 10:54:26 +0000
committerRicardo Wurmus <rekado@elephly.net>2017-06-01 23:29:23 +0200
commitdec63df4ff09d8db2fbeb090e86af7c7a8a8fc22 (patch)
treeba8a3895614a6c3c9fed1ac1e9e8cab957bd2053 /gnu/packages/games.scm
parent924e6ddf72b8c6f5392ea64528072b20264210ae (diff)
downloadguix-dec63df4ff09d8db2fbeb090e86af7c7a8a8fc22.tar
guix-dec63df4ff09d8db2fbeb090e86af7c7a8a8fc22.tar.gz
gnu: Add open-adventure.
* gnu/packages/games.scm (open-adventure): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm58
1 files changed, 57 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 60d885500c..10cf1b1e2e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2016, 2017 Rodger Fox <thylakoid@openmailbox.org>
;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
-;;; Copyright © 2016, 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2016, 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;; Copyright © 2016 Albin Söderqvist <albin@fripost.org>
;;; Copyright © 2016, 2017 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
@@ -66,6 +66,7 @@
#:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages docbook)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
@@ -4272,3 +4273,58 @@ at their peak of economic growth and military prowess.
license:lgpl3
license:mpl2.0
license:zlib))))
+
+;; There have been no official releases.
+(define-public open-adventure
+ (let* ((commit "2483a23690d205f01ecb66165cf4522b541cd991")
+ (revision "1"))
+ (package
+ (name "open-adventure")
+ (version (string-append "2.5-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/esr/open-adventure")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1gkvkwbq5cl3llfc7nl41van8awn4myx782pg33bxpbx5l9scwb4"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "CC=gcc")
+ #:parallel-build? #f ; not supported
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'use-echo
+ (lambda _
+ (substitute* "tests/Makefile"
+ (("/bin/echo") (which "echo")))
+ #t))
+ (add-after 'build 'build-manpage
+ (lambda _
+ ;; This target is missing a dependency
+ (substitute* "Makefile"
+ ((".asc.6:" line)
+ (string-append line " advent.txt")))
+ (zero? (system* "make" ".asc.6"))))
+ ;; There is no install target
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (man (string-append out "/share/man/man6")))
+ (install-file "advent" bin)
+ (install-file "advent.6" man))
+ #t)))))
+ (native-inputs
+ `(("asciidoc" ,asciidoc)))
+ (home-page "https://gitlab.com/esr/open-adventure")
+ (synopsis "Colossal Cave Adventure")
+ (description "The original Colossal Cave Adventure from 1976 was the
+origin of all text adventures, dungeon-crawl (computer) games, and
+computer-hosted roleplaying games. This is the last version released by
+Crowther & Woods, its original authors, in 1995. It has been known as
+\"adventure 2.5\" and \"430-point adventure\".")
+ (license license:bsd-2))))