aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-07-12 10:50:32 -0400
committerKei Kebreau <kei@openmailbox.org>2017-07-12 10:51:19 -0400
commit5149ff1b5f0c6c1e66a0702f14a1010fc6feb105 (patch)
tree12823247c8425bb37654bb300e32f75a41a39ca0 /gnu/packages/games.scm
parent911a53a53f4898c386cbb7347daf928fae592fa3 (diff)
downloadguix-5149ff1b5f0c6c1e66a0702f14a1010fc6feb105.tar
guix-5149ff1b5f0c6c1e66a0702f14a1010fc6feb105.tar.gz
gnu: hyperrogue: Update to 9.4n.
* gnu/packages/games.scm (hyperrogue): Update to 9.4n.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index a7f697ece4..2bef92b93b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3493,7 +3493,7 @@ throwing people around in pseudo-randomly generated buildings.")
(define-public hyperrogue
(package
(name "hyperrogue")
- (version "9.4g")
+ (version "9.4n")
;; When updating this package, be sure to update the "hyperrogue-data"
;; origin in native-inputs.
(source (origin
@@ -3504,10 +3504,11 @@ throwing people around in pseudo-randomly generated buildings.")
"-src.tgz"))
(sha256
(base32
- "09j9gnx701x28zfkrv3rjqlr56p89hyxk78gkpmmdfjgcq076pc2"))))
+ "1kf9i9gqadnb0m143c860dcvdn91vp6vnfzma4bcgfgwmcn9sx0r"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:make-flags '("CXXFLAGS=-std=c++11")
#:phases
(modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
@@ -3578,7 +3579,7 @@ throwing people around in pseudo-randomly generated buildings.")
"-win.zip"))
(sha256
(base32
- "1r57db4hm7fjcd27p8b6cdsnq2cgkym2kp9lrw7ha2asdf8w6gkb"))))
+ "1vrk0k0ch3azpa72y7acmmpifvks6c0466fvmz804hici93pglvi"))))
("unzip" ,unzip)))
(inputs
`(("font-dejavu" ,font-dejavu)