aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRodger Fox <thylakoid@openmailbox.org>2016-02-15 20:07:04 -0500
committerLeo Famulari <leo@famulari.name>2016-02-15 20:12:08 -0500
commit7e2e115501ad7f6622f4cddca37a34a63582292d (patch)
tree8f5b46a02715af8eda40aa5d89372a8f5e87088f /gnu/packages/games.scm
parentbe6f30047e5b6312870d03e0666ce011be449746 (diff)
downloadguix-7e2e115501ad7f6622f4cddca37a34a63582292d.tar
guix-7e2e115501ad7f6622f4cddca37a34a63582292d.tar.gz
gnu: Add pioneers.
* gnu/packages/games.scm (pioneers): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7eb0e7a630..4cc96ca49e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
+;;; Copyright © 2016 Rodger Fox <thylakoid@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -44,6 +45,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages admin)
#:use-module (gnu packages audio)
+ #:use-module (gnu packages avahi)
#:use-module (gnu packages boost)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages game-development)
@@ -1891,3 +1893,27 @@ and a game metadata scraper.")
(description "The Emilia Pinball Project is a pinball simulator. There
are only two levels to play with, but they are very addictive.")
(license license:gpl2)))
+
+(define-public pioneers
+ (package
+ (name "pioneers")
+ (version "15.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://downloads.sourceforge.net/pio/"
+ "pioneers-" version ".tar.gz"))
+ (sha256
+ (base32
+ "128s718nnraiznbg2rajjqb7cfkdg24hy6spdd9narb4f4dsbbv9"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)
+ ("avahi" ,avahi)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Board game inspired by The Settlers of Catan")
+ (description "Pioneers is an emulation of the board game The Settlers of
+Catan. It can be played on a local network, on the internet, and with AI
+players.")
+ (home-page "http://pio.sourceforge.net/")
+ (license license:gpl3+)))