aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-07-04 11:35:14 -0400
committerKei Kebreau <kei@openmailbox.org>2016-07-04 11:36:38 -0400
commit35e2e495771ea93d26107fb4f35635922cfe299c (patch)
tree3b8694f57d5cbc926801f7323c9d3019b0f24ff4 /gnu/packages/games.scm
parent744004a31f5463a1fa3cd367fee7f4a242651da8 (diff)
downloadguix-35e2e495771ea93d26107fb4f35635922cfe299c.tar
guix-35e2e495771ea93d26107fb4f35635922cfe299c.tar.gz
gnu: Add chromium-bsu.
* gnu/packages/games.scm (chromium-bsu): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1fb8c71573..608c567c5c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2492,3 +2492,39 @@ in strikes against the evil corporation.")
license:cc-by-sa3.0
license:cc0
license:public-domain))))
+
+(define-public chromium-bsu
+ (package
+ (name "chromium-bsu")
+ (version "0.9.15.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name
+ "/Chromium B.S.U. source code/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "01c4mki0rpz6wrqbf18fj4vd7axln5v0xqm80cyksbv63g04s6w6"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'set-paths 'set-sdl-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "sdl-union")
+ "/include/SDL"))
+ #t)))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("glu" ,glu)
+ ("quesoglc" ,quesoglc)
+ ("sdl-union" ,(sdl-union (list sdl sdl-image sdl-mixer)))))
+ (home-page "http://chromium-bsu.sourceforge.net/")
+ (synopsis "Fast-paced, arcade-style, top-scrolling space shooter")
+ (description
+ "In this game you are the captain of the cargo ship Chromium B.S.U. and
+are responsible for delivering supplies to the troops on the front line. Your
+ship has a small fleet of robotic fighters which you control from the relative
+safety of the Chromium vessel.")
+ ;; Clarified Artistic License for everything but sound, which is covered
+ ;; by the Expat License.
+ (license (list license:clarified-artistic license:expat))))