aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-19 18:02:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-19 18:02:43 +0200
commitda9adfc7f7e11e6aeaa6322331e867bbafdab055 (patch)
tree7650e220a018210e0872a4cb5236b06cceedcf33 /gnu/packages/games.scm
parent57d87f435fcb05a8e44a6d0545d0212429826bd0 (diff)
downloadguix-da9adfc7f7e11e6aeaa6322331e867bbafdab055.tar
guix-da9adfc7f7e11e6aeaa6322331e867bbafdab055.tar.gz
gnu: colobot, leela-zero: Add Boost workaround.
This works around and incompatibility with CMake 3.14 and Boost 1.70, see <https://bugs.gnu.org/36721>. * gnu/packages/games.scm (colobot, leela-zero)[arguments]: Add "-DBoost_NO_BOOST_CMAKE=ON" in <#:configure-flags>.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1088d2ff4b..30fa0463f4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5397,6 +5397,8 @@ Github or Gitlab.")
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test
+ ;; XXX: Work around <https://bugs.gnu.org/36721>.
+ #:configure-flags '("-DBoost_NO_BOOST_CMAKE=ON")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'make-git-checkout-writable
@@ -7621,7 +7623,9 @@ remake of that series or any other game.")
("qtbase" ,qtbase)
("zlib" ,zlib)))
(arguments
- '(#:configure-flags '("-DUSE_BLAS=YES")
+ '(#:configure-flags '("-DUSE_BLAS=YES"
+ ;; XXX: Work around <https://bugs.gnu.org/36721>.
+ "-DBoost_NO_BOOST_CMAKE=ON")
#:phases (modify-phases %standard-phases
(add-before 'configure 'fix-tests
(lambda* (#:key outputs #:allow-other-keys)