aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-04-10 21:38:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-04-11 09:43:18 +0200
commitf0f7bf95aebbe30d2a8bae31cff1cb86884f458b (patch)
tree9c357d24e184e51aff06a1e67c209848fd150554 /gnu/packages/games.scm
parentcd12f922246ae798ec248768713848d939d31ea0 (diff)
downloadguix-f0f7bf95aebbe30d2a8bae31cff1cb86884f458b.tar
guix-f0f7bf95aebbe30d2a8bae31cff1cb86884f458b.tar.gz
gnu: Add cdogs-sdl.
* gnu/packages/games.scm (cdogs-sdl): New variable.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ed04239c69..71f35e2fef 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -3515,3 +3515,40 @@ emerges from a sewer hole and pulls her below ground.")
license:expat
license:public-domain
license:cc-by-sa3.0)))))
+
+(define-public cdogs-sdl
+ (package
+ (name "cdogs-sdl")
+ (version "0.6.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/cxong/cdogs-sdl/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08c3y8ijimx6mp0gm90abz4lsnbflqka519q2v0id0096vsc2pxn"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list (string-append "-DCDOGS_DATA_DIR="
+ (assoc-ref %outputs "out")
+ "/share/cdogs-sdl/"))))
+ (inputs
+ `(("sdl2" ,sdl2)
+ ("sdl2-image" ,sdl2-image)
+ ("sdl2-mixer" ,sdl2-mixer)))
+ (home-page "http://cxong.github.io/cdogs-sdl/")
+ (synopsis "Classic overhead run-and-gun game")
+ (description "C-Dogs SDL is a classic overhead run-and-gun game,
+supporting up to 4 players in co-op and deathmatch modes. Customize your
+player, choose from many weapons, and blast, slide and slash your way through
+over 100 user-created campaigns.")
+ ;; GPLv2+ for code (includes files under BSD-2 and BSD-3),
+ ;; CC0/CC-BY/CC-BY-SA for assets.
+ (license (list license:gpl2+
+ license:bsd-2
+ license:bsd-3
+ license:cc0
+ license:cc-by3.0
+ license:cc-by-sa3.0))))