aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-09-13 22:35:02 +0530
committerKei Kebreau <kkebreau@posteo.net>2017-09-22 08:04:32 -0400
commitc17b079043ba6dc20b4aa690a7d30eb8d9680f63 (patch)
tree04f9b704371f45da805e7cc0553e9438f05c4a9e /gnu/packages/games.scm
parent2374dee7bcaeac64741011e55df151ef2a051164 (diff)
downloadguix-c17b079043ba6dc20b4aa690a7d30eb8d9680f63.tar
guix-c17b079043ba6dc20b4aa690a7d30eb8d9680f63.tar.gz
gnu: Add openttd-opensfx.
* gnu/packages/games.scm (openttd-opensfx): New variable. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 7bfd05cc7f..ed386fc843 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2525,6 +2525,44 @@ OpenGFX provides you with...
@end enumerate")
(license license:gpl2)))
+(define openttd-opensfx
+ (package
+ (name "openttd-opensfx")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://binaries.openttd.org/extra/opensfx/"
+ version "/opensfx-" version "-source.tar.gz"))
+ (sha256
+ (base32
+ "03jxgp02ks31hmsdh4xh0xcpkb70ds8jakc9pfc1y9vdrdavh4p5"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("catcodec" ,catcodec)
+ ("python" ,python2-minimal)))
+ (arguments
+ `(#:make-flags
+ (list (string-append "INSTALL_DIR=" %output
+ "/share/games/openttd/baseset/opensfx"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ ;; Remove the time dependency of the installed tarball by setting
+ ;; the modification times if its members to 0.
+ (substitute* "scripts/Makefile.def"
+ (("-cf") " --mtime=@0 -cf"))
+ #t))
+ (delete 'configure))))
+ (home-page "http://dev.openttdcoop.org/projects/opensfx")
+ (synopsis "Base sounds for OpenTTD")
+ (description "OpenSFX is a set of free base sounds for OpenTTD which make
+it possible to play OpenTTD without requiring the proprietary sound files from
+the original Transport Tycoon Deluxe.")
+ (license license:cc-sampling-plus-1.0)))
+
(define-public openttd
(package
(inherit openttd-engine)