aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 17:42:53 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-11 18:01:18 +0200
commit7e1d376d304ad1c60007cfd06aae0fae0cd76642 (patch)
tree4848b7d7b7d5846776e86087a25981c7f554453f /gnu/packages/games.scm
parent2f9891725d3c375134b0d8e97e0033df1fe516da (diff)
downloadguix-7e1d376d304ad1c60007cfd06aae0fae0cd76642.tar
guix-7e1d376d304ad1c60007cfd06aae0fae0cd76642.tar.gz
gnu: fortune-mod: Don't use unstable tarball.
* gnu/packages/games.scm (fortune-mod)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 453f732a5d..2744d46a9c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5193,13 +5193,16 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
(package
(name "fortune-mod")
(version "2.4.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/shlomif/fortune-mod/"
- "archive/" name "-" version ".tar.gz"))
- (sha256
- (base32
- "1hnqpkassh7fwg2jgvybr8mw7vzfikbrhb5r22367ilfwxnl9yd2"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/shlomif/fortune-mod")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1ayicdqjm9vfngp89kjw778q6lnawgc08zgn5l8ld4zd7ip11s8c"))))
(build-system cmake-build-system)
(arguments
`(#:test-target "check"