aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/games.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-17 23:21:00 -0400
committerLeo Famulari <leo@famulari.name>2016-08-17 23:35:22 -0400
commit015ee84aac888b3900fa0ee54a1b7e55c083e7d3 (patch)
tree2ef7a51321dff53e479bc6d11f3785e1c65c07f0 /gnu/packages/games.scm
parenta3d6e1f432ad5f9cde8bee670b28646e05c4cb19 (diff)
parent79f9d5d5dc97e492e0583e039a2699aa17f4eb11 (diff)
downloadguix-015ee84aac888b3900fa0ee54a1b7e55c083e7d3.tar
guix-015ee84aac888b3900fa0ee54a1b7e55c083e7d3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/games.scm')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e467dbe04c..96aefbc3e4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il"
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -74,6 +75,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages netpbm)
+ #:use-module (gnu packages ocaml)
#:use-module (gnu packages python)
#:use-module (gnu packages readline)
#:use-module (gnu packages xorg)
@@ -2678,6 +2680,7 @@ with the \"Stamp\" tool within Tux Paint.")
"CONFDIR=/etc/tuxpaint" ;don't write to store
,(string-append "PREFIX=" %output)
"GNOME_PREFIX=$(PREFIX)")
+ #:parallel-build? #f ;race conditions
#:tests? #f ;no tests
#:phases (modify-phases %standard-phases
(delete 'configure) ;no configure phase
@@ -2731,3 +2734,42 @@ in a style similar to the original Super Mario games covered under
the GNU GPL.")
(home-page "https://supertuxproject.org/")
(license license:gpl3+)))
+
+(define-public laby
+ (package
+ (name "laby")
+ (version "0.6.4")
+ (source
+ (origin (method url-fetch)
+ (uri (string-append
+ "https://github.com/sgimenez/laby/tarball/"
+ name "-" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "113ip48308ps3lsw427xswgx3wdanils43nyal9n4jr6bcx1bj2j"))
+ (patches (search-patches "laby-make-install.patch"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("lablgtk" ,lablgtk)
+ ("ocaml" ,ocaml)
+ ("ocaml-findlib" ,ocaml-findlib)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-before 'build 'setenv
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((lablgtk (assoc-ref inputs "lablgtk")))
+ (setenv "LD_LIBRARY_PATH"
+ (string-append lablgtk "/lib/ocaml/stublibs"))))))
+ #:tests? #f ; no 'check' target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")) "all")))
+ (home-page "https://sgimenez.github.io/laby/")
+ (synopsis "Programming game")
+ (description "Learn programming, playing with ants and spider webs ;-)
+Your robot ant can be programmed in many languages: OCaml, Python, C, C++,
+Java, Ruby, Lua, JavaScript, Pascal, Perl, Scheme, Vala, Prolog. Experienced
+programmers may also add their own favorite language.")
+ (license license:gpl3+)))