aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-02-21 18:53:19 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-02-22 11:31:30 +0100
commit052f75da754b1d6aae00049f732a3bb549147e0f (patch)
tree09513c5ae56e6ceff341e9d8d026ba880018a605 /gnu/packages/game-development.scm
parentc0185d8e84047f4e209dbc217bbece9921aaf745 (diff)
downloadguix-052f75da754b1d6aae00049f732a3bb549147e0f.tar
guix-052f75da754b1d6aae00049f732a3bb549147e0f.tar.gz
gnu: python-pygame: Update to 1.9.3.
* gnu/packages/game-development.scm (python-pygame)[version]: Update to 1.9.3. [source]: Use pypi-uri. [inputs]: Add freetype. [arguments]: Use python-3 instead of python-2. Provide path to freetype library in 'set-library-paths' phase. Remove "src/movie.c" dummy substitution. (python2-pygame): New variable.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm24
1 files changed, 16 insertions, 8 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 619c2f1bc2..908ce48347 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -526,18 +526,16 @@ interface (API).")
(define-public python-pygame
(package
(name "python-pygame")
- (version "1.9.1")
+ (version "1.9.3")
(source (origin
(method url-fetch)
- (uri (string-append "http://pygame.org/ftp/pygame-"
- version "release.tar.gz"))
+ (uri (pypi-uri "pygame" version))
(sha256
(base32
- "0cyl0ww4fjlf289pjxa53q4klyn55ajvkgymw0qrdgp4593raq52"))))
+ "1hlydiyygl444bq5m5g8n3jsxsgrdyxlm42ipmfbw36wkf0j243m"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:tests? #f ; Tests require pygame to be installed first.
+ `(#:tests? #f ; Tests require pygame to be installed first.
#:phases
(modify-phases %standard-phases
;; Set the paths to the dependencies manually because
@@ -553,6 +551,7 @@ interface (API).")
(smpeg-ref (assoc-ref inputs "libsmpeg"))
(png-ref (assoc-ref inputs "libpng"))
(jpeg-ref (assoc-ref inputs "libjpeg"))
+ (freetype-ref (assoc-ref inputs "freetype"))
(v4l-ref (assoc-ref inputs "v4l-utils"))
(out-ref (assoc-ref outputs "out")))
(substitute* "Setup.in"
@@ -582,9 +581,14 @@ interface (API).")
(("JPEG = -ljpeg")
(string-append "JPEG = -I" jpeg-ref "/include -L"
jpeg-ref "/lib -ljpeg")))
+
+ (substitute* "Setup.in"
+ (("FREETYPE = -lfreetype")
+ (string-append "FREETYPE = -I" freetype-ref "/include/freetype2 -L"
+ freetype-ref "/lib -lfreetype")))
+
(substitute* "Setup.in"
(("^pypm") "#pypm"))
- (substitute* "src/movie.c")
;; Create a path to a header file provided by v4l-utils.
(system* "mkdir" "linux")
(system* "ln" "--symbolic"
@@ -592,7 +596,8 @@ interface (API).")
"linux/videodev.h")
(system* "ln" "--symbolic" "Setup.in" "Setup")))))))
(inputs
- `(("sdl" ,sdl)
+ `(("freetype" ,freetype)
+ ("sdl" ,sdl)
("sdl-image" ,sdl-image)
("sdl-mixer" ,sdl-mixer)
("sdl-ttf" ,sdl-ttf)
@@ -619,3 +624,6 @@ to create fully featured games and multimedia programs in the python language.")
license:psfl
license:public-domain
license:lgpl2.1+))))
+
+(define-public python2-pygame
+ (package-with-python2 python-pygame))