aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2020-09-09 20:12:53 -0400
committerKei Kebreau <kkebreau@posteo.net>2020-09-09 20:56:54 -0400
commit762c89fb20faf84796113239ea6254e51c4d73fa (patch)
tree86fe515741bc61fb4e6d73a9e7cfeb37a2750943 /gnu/packages/game-development.scm
parent6a5a882bc63597e7442883315b8061de4e36195d (diff)
downloadguix-762c89fb20faf84796113239ea6254e51c4d73fa.tar
guix-762c89fb20faf84796113239ea6254e51c4d73fa.tar.gz
gnu: python-sge: Update to 1.7.
* gnu/packages/game-development.scm (python-sge-pygame): Define as deprecated alias for python-sge. (python2-sge-pygame): Remove unsupported Python 2 variant. (python-sge)[source]: Use pypi-uri. [propagated-inputs]: Remove python-six. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 4740546dbe..0f48803f41 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2015, 2018 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2017, 2020 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Julian Graham <joolean@gmail.com>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -342,26 +342,22 @@ compiling NML files (along with their associated language, sound and graphic
files) into @file{.grf} and/or @file{.nfo} files.")
(license license:gpl2+)))
-(define-public python-sge-pygame
+(define-public python-sge
(package
- (name "python-sge-pygame")
- (version "1.5.1")
+ (name "python-sge")
+ (version "1.7")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://savannah/stellarengine/"
- (version-major+minor version) "/sge-pygame-"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "sge" version))
(sha256
(base32
- "1rl3xjzh78sl0sq3xl8rl7cgp9v9v3h7s2pfwn7nj1vrmffzkcpd"))))
+ "02fn6v6bxk3sngwd4kd3mglrp0jlnhx7x6h8nnkik6wdv150a0wv"))))
(build-system python-build-system)
(propagated-inputs
`(("python-pygame" ,python-pygame)
- ("python-six" ,python-six)
("python-uniseg" ,python-uniseg)))
- (home-page "http://stellarengine.nongnu.org")
+ (home-page "https://python-sge.github.io/")
(synopsis "2D game engine for Python")
(description
"The SGE Game Engine (\"SGE\", pronounced like \"Sage\") is a
@@ -370,8 +366,8 @@ you can focus on the game itself. This makes more rapid game development
possible, and it also makes the SGE easy to learn.")
(license license:lgpl3+)))
-(define-public python2-sge-pygame
- (package-with-python2 python-sge-pygame))
+(define-public python-sge-pygame
+ (deprecated-package "python-sge-pygame" python-sge))
(define-public python-tmx
(package