aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-04-30 19:12:34 +0200
committerLudovic Courtès <ludo@gnu.org>2018-04-30 23:41:21 +0200
commit1798e9ee97016ec58dc17ae95a73814e9ebc2ebe (patch)
tree0a216b7444339be87c4c9caa8b4abd3d99a361de /gnu/packages/game-development.scm
parent350f50cbd35b6d1544734a4c6b2d7d43df4ac03c (diff)
downloadguix-1798e9ee97016ec58dc17ae95a73814e9ebc2ebe.tar
guix-1798e9ee97016ec58dc17ae95a73814e9ebc2ebe.tar.gz
gnu: gzochi: Build without '-Werror'.
Previously it would fail to build due to GLib deprecation warnings. * gnu/packages/game-development.scm (gzochi)[arguments]: New field.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 86abf9f37c..1374676314 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Tomáš Čech <sleep_walker@suse.cz>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016, 2017 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
@@ -233,6 +233,15 @@ PCM data.")
(base32
"13j1m92zhxwkaaja3lg5x0h0b28mrrawdzk9d3hd19031akfxwb3"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'build 'no-Werror
+ (lambda _
+ ;; Don't abort builds due to things like GLib
+ ;; deprecation warnings.
+ (substitute* (find-files "." "^Makefile\\.in$")
+ (("-Werror") ""))
+ #t)))))
(native-inputs `(("pkgconfig" ,pkg-config)))
(inputs `(("bdb" ,bdb)
("glib" ,glib)