aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-02-24 21:25:52 +0100
commitaa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc (patch)
tree5ccb7f83712c4400176a344e537b5fcbbb7047aa /gnu/packages/game-development.scm
parent1b9eb93a5dd1e90291b614311cd1fb2051e72718 (diff)
parent6eb35d4a780d37b809a6c8c1794ff227da2fa29d (diff)
downloadguix-aa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc.tar
guix-aa51eb2073f17e40d660d0beaeb7b1b78aa9e1cc.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 8 insertions, 15 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ac01cb3f2f..7f00f7080b 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1005,28 +1005,21 @@ painted with a mouse.")
(define-public ois
(package
(name "ois")
- (version "1.3")
+ (version "1.5")
(source
(origin
- ;; Development has moved to github and there are no recent tarball
- ;; releases.
(method git-fetch)
(uri (git-reference
(url "https://github.com/wgois/OIS.git")
- (commit "bb75ccc1aabc1c547195579963601ff6080ca2f2")))
- (file-name (string-append name "-" version))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0w0pamjc3vj0jr718hysrw8x076fq6n9rd6wcb36sn2jd0lqvi98"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("m4" ,m4)
- ("pkg-config" ,pkg-config)))
+ (base32 "0g8krgq5bdx2rw7ig0xva4kqv4x815672i7z6lljp3n8847wmypa"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no test suite
(inputs
- `(("libxaw" ,libxaw)))
+ `(("libx11" ,libx11)))
(synopsis "Object Oriented Input System")
(description
"Cross Platform Object Oriented Input Lib System is a cross platform,