aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/game-development.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-24 14:00:32 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-24 14:00:32 +0100
commit24c4b012ee9789e2e767da826d9dccf71bbad3b5 (patch)
tree7a3f172381d44ebf8ae60a33838f2d261b3eaabf /gnu/packages/game-development.scm
parent4041fabb1ff6b3a6b05453135f5550794d38a8b0 (diff)
downloadguix-24c4b012ee9789e2e767da826d9dccf71bbad3b5.tar
guix-24c4b012ee9789e2e767da826d9dccf71bbad3b5.tar.gz
gnu: Add bennu-game-development-modules.
* gnu/packages/game-development.scm (bennu-game-development-modules): New variable.
Diffstat (limited to 'gnu/packages/game-development.scm')
-rw-r--r--gnu/packages/game-development.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index f6dd401f24..e67f10aec6 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1375,3 +1375,27 @@ programming language tailored at game development. It is the successor of
Fenix.")
(home-page "https://sourceforge.net/projects/bennugd/")
(license license:zlib)))
+
+(define-public bennu-game-development-modules
+ (package
+ (inherit bennu-game-development)
+ (name "bennu-game-development-modules")
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-conflicting-definitions
+ (lambda _
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "core/include/fmath.h"
+ (("extern fixed fmul\\( int x, int y \\);") "")
+ (("extern fixed fdiv\\( int x, int y \\);") "")))
+ (chdir "modules"))))))
+ (inputs `(("zlib" ,zlib)
+ ("libpng" ,libpng)
+ ("openssl" ,openssl)
+ ("sdl-mixer" ,sdl-mixer)
+ ("bennu-game-development" ,bennu-game-development)))
+ (synopsis "Modules for the Bennu Game Developement programming language")
+ (description "This package contains a collection of modules for the Bennu
+Game Developement programming language, from CD handling through SDL to
+joystick support.")))